Weird non-domain joined DNS query results vs. domain joined

Traveler856 1 Reputation point

I just setup a WS2019 lab, which has two DCs with integrated DNS. I have forward and reverse lookup zones for both of my networks. The domain is "lab.local". If I run nslookup queries on either DC, using the short name or FQDN, I get the expected DNS results. However, what I can't explain is what happens on a non-domain joined Windows 10 computer, or a Mac.

Both the non-domain joined Win10 PC and Mac are pointed to the lab.local DNS server IP addresses. If on the PC/Mac I execute 'nslookup addc01.lab.local' I get:

C:\Users\DS>nslookup addc01.lab.local
Server: UnKnown

*** UnKnown can't find addc01.lab.local: Non-existent domain

But as I mentioned earlier, running that same FQDN nslookup on either DC gives me the proper result. If I 'force' nslookup to query my lab DCs, I still get the same failed result:

C:\Users\DS>nslookup addc01.lab.local
Server: UnKnown

*** UnKnown can't find addc01.lab.local: No response from server

and running that from a lab DC:

C:\Users\Administrator>nslookup addc01.lab.local
Server: ADDC01.lab.local

Name: addc01.lab.local

I've setup dozens of lab DCs like these before, and never had such inconsistent DNS resolution for non-domain joined computers. Any ideas?

I should mention the PC/Mac are on a different LAN network from the DCs (10.13.2.x). I provisioned a dummy WS2019 VM on the same network as the DCs (not domain joined), and the nslookup queries DO behave as I would expect (i.e they work).

Windows DHCP
Windows DHCP
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.DHCP: Dynamic Host Configuration Protocol (DHCP). A communications protocol that lets network administrators manage centrally and automate the assignment of Internet Protocol (IP) addresses in an organization's network.
965 questions
{count} votes

1 answer

Sort by: Most helpful
  1. Sunny Qi 10,746 Reputation points Microsoft Vendor


    Thanks for posting in Q&A platform.

    Based on provided information, my understanding is that addc01.lab.local is your DC&DNS server. When you run nslookup addc01 from windows client, you will get the expected result from DNS server. But when you run nslookup addc01.lab.local, you just get the error and the FQDN cannot be resolved to IP address. Please correct me if my understanding is wrong.

    Meanwhile, I noticed that you mentioned that the windows client is on a different LAN network from the DCs (10.13.2.x). May I know if the client is on the same subnet or different subnet with DC?

    Please help provide screenshots of result of ipconfig /all of your windows client and the result of nslookup addc01 for further troubleshooting.

    Please kindly note that this forum is a public forum that everyone can view this thread, when you post the required screenshots please remove your private information.

    Best Regards,


    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    0 comments No comments