Cannot Insert Excel in Word with Office 365

Quentin Styger 1 Reputation point

When adding an Excel object in Word, it fails and returns the following error:
The program used to create this object is Excel. That program is either not installed on your computer or it is not responding. To edit this object, install Excel or ensure that any dialog boxes in Excel are closed.

I have Excel installed and this feature in Word was functional ~3 days ago when I last used it. There have been no system changes or changes to my system state between the last known good and today's fault.

I've tried using the feature with Excel opened, closed and after restarting my computer, Excel closed and opened for a total of 4 independent tests and the same error as above.
I can insert tables and quick tables, but not Excel spreadsheet, not even with a fresh blank document after closing the program and restarting the computer.
I only have 1 instance of Office installed on my computer.
I only have one MS Account with the full Office 365 suite.
I am the only person with access to my computer.

Windows Defender and Malwarebytes do not detect any issues with my computer. All updates and drivers are current at the time of writing this question.

Excel operates without issue as a standalone program, however I would like to add an excel sheet into my word document like I could a few days ago.

Office Development
Office Development
Office: A suite of Microsoft productivity software that supports common business tasks, including word processing, email, presentations, and data management and analysis.Development: The process of researching, productizing, and refining new or existing technologies.
2,425 questions
Word Management
Word Management
Word: A family of Microsoft word processing software products for creating web, email, and print documents.Management: The act or process of organizing, handling, directing or controlling something.
806 questions
{count} votes

5 answers

Sort by: Most helpful
  1. Derek Scott 11 Reputation points

    Run word as administrator - this fixed it for me

    2 people found this answer helpful.

  2. Emily Hua-MSFT 26,841 Reputation points Microsoft Vendor

    @Quentin Styger

    I would give some suggestions above your description, you may have a look.

    • Please go to Excel > Options > Advanced > General part, make sure "Ignore other applications that use Dynamic Data Exchange (DDE)" is not ticked.
    • Then go to Add-ins under Advanced option> Manage, COM add-ins > Go, clear the check boxes for any enabled COM add-ins, select OK, then check this issue again.
    • Besides, I suggest you right-click the Word and Excel icons on the desktop, and click Compatibility tab, ensure the box of "Run this program in compatibility mode for:" is not ticked too.
    • Temporarily disable Malwarebytes for a test.
    • If these steps above do not work, it's recmmended to perfer an Online Repair for Office to have a check.

    Any updates, please let me know.

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

  3. Duperron, Alex 1 Reputation point

    I was trying the mailing function in my Word document, using an external Excel file for reference.
    After several saved version on the same One drive folder(yyy_01.docx, yyy_02.docx, yyy_03.docx...), I changed my mind and decided to look for macros instead of the mail merge due to limitations.
    Instead of restarting from scratch, I kept my last version and removed any reference to that external Excel file, then again save a new version of my Word document to the same folder.
    Then I tried to insert an Excel file and this is where I started receiving the error message.
    The only way a was able to get around this, was to save my Word document to another folder.
    If I put a copy of the new document that now works back to that same folder(even sub folder), it fails again.

    0 comments No comments

  4. Giovanni G 1 Reputation point

    Hi to all

    im new here and this is my first answer in my life and hope that this can help you to solve the problem

    In my PC for the issue reported :

    "The program used to create this object is Excel. That program is either not installed on your computer or it is not responding. To edit this object, install Excel or ensure that any dialog boxes in Excel are closed"

    I tried to log into the system on my pc as a different user and inserting excel or other object, using the command in word, it go.

    The problem was related to my local profile on win10 x64 bit.

    So i logged to the system as Administrator.

    on Control Panel ->System -> Advanced system settings->on Advanced profile tab-> user profile -> select Settings
    you'll verify users created on operating system.

    I verified that my profile was corrupted and "Copy to" command was disabled.

    Using windows explorer under C:\User\MyUser I tried to do manually backup of my profile copying Desktop, Documents, Download, Favorites (Browser) and Hidden system folder "Local" under "Appdata" in "user" profile folder.

    After the backup of my profile always as Administrator on the system using the same path
    Control Panel ->System -> Advanced system settings->on Advanced profile tab-> user profile -> Settings
    I selected my Account and pressed on "Delete".

    Restart the PC and tried log in to the system, using my personal Microsoft Account.
    I opened a new word document and using insert function of Word i have inserted Excel Worksheet, hyperlink or any other object present, with success.

    The procedure described go in my case i have not responsibility if you try and you lose personal data.

    0 comments No comments

  5. Muthukumaran Ganesan 0 Reputation points

    Click on "Enable Editing" in the Excel file and Save.
    Then try importing it into the Word.
    This worked for me.

    0 comments No comments