Cannot get wvd to assign to a user

Niek 1 Reputation point


Today I made a windows virtual desktop deployment. Everything went smoothly until browsed to the html5 landing page. It always gives this error:

It looks like your system administrator hasn’t set up any resources for <user> yet. Please choose a different account or try again. If you believe you have received this message in error, please contact your system administrator.

The pool is online, I added the users, but nothing seems to fix it.

I've tried the following:

Add-RdsAccount -DeploymentUrl &#34;;

This logs me in with my azure ad account, but does nothing to fix the error.

I also have a azure ad domain services installed. My vnet and the vm are in the same virtual network.

I also tried this:

Add-RdsAppGroupUser &lt;WVDTENANTNAME&gt; &lt;HOSTPOOLNAME&gt; &#34;Desktop Application Group&#34; -UserPrincipalName

But then I get the following error:

Add-RdsAppGroupUser : User is not authorized to query the management service.
ActivityId: c6ed4bc5-66bb-45bf-bd70-9092c540bb10

I just want all of my users to be able to login to a virtual device with admin rights and have office / teams ect.


Azure Virtual Desktop
Azure Virtual Desktop
A Microsoft desktop and app virtualization service that runs on Azure. Previously known as Windows Virtual Desktop.
1,047 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Stefan Georgiev-MSFT 96 Reputation points

    Please follow the instructions here I am sorry but it seems there are a lot of steps missing in what has been described. Please check:
    1)does the user you login with to do the role assignments has tenant creator
    2)what is the URL for the web client?
    3)what is the tenant that has been created, is the same tenant being used when assigning permissions

    1 person found this answer helpful.
    0 comments No comments

  2. Stefan Georgiev-MSFT 96 Reputation points

    There will be a SSO instructions coming. Right now it works only in a very narrow set of constraints.
    There are registry entries to set Office activation but they are not officially supported. Not sure if we had a policy we support.

    1 person found this answer helpful.
    0 comments No comments

  3. Niek 1 Reputation point

    Hi @stefangeorgiev

    Thanks for the answer. Finally found out that there is a new url if you are using the spring 2020 wvd release. Signed in to that and it worked.

    Still have a couple of questions though:

    1: Is it possible to automatically activate the office license so that a user does not have to manually activate it?

    2: Is there some form of sso possible? Instead of signing in with azure ad >> domain\username >> logged in.

    Thanks :)