SharePoint 2019 on-prem doesn't create crawled properties

elephantballoon 106 Reputation points
2021-03-18T13:47:41.037+00:00

I'm really stumped with this one, so it's time to ask for help. We are creating a new 2019 SharePoint on-prem farm, and I'm having big issues with the search. The biggest one is that it doesn't create crawled properties - or rather, it sometimes creates them and sometimes not. This is going to be a long explanation, so bear with me.

I have two farms (test and future production) and I have been testing things with both of them, so I'm sure I can repeat these issues. Both farm have at least one app, one frontend with distributed cache, and one search server.

First, I installed SP2019 and August 2020 CU on each server and created a farm. I used a setup account when installing and made sure rights are set as described in this article. Then I used SharePoint DSC to configure the farm, again using a setup account. The configuration has been the same for all iterations. There are two content sources: Local SharePoint sites and an external web page.

With the August 2020 CU, I couldn't get SharePoint to find any crawled properties from either one of those content sources. Health is good, crawl log says content is indexed, I can find it if I try to search for it. But none of the columns or website metadata appears in the crawled properties. I tried to check database rights and permisisons to web application and metadata service application, and everything looks like it's correct. I found reports that SharePoint Online's Team Sites have had trouble with crawled properties (references here and here), so I though something might be wrong with the CU. I tried installing the January 2021 CU, but it didn't fix things.

Next I nuked those two farms and reinstalled them completely. I didn't install any CU, just the original SharePoint 2019 binaries, and then configured the farm with the same script as before. Now the crawled properties appeared just like they should, so everything good so far. Note that I did no changes to the configuration and I used the same content database backups, so the only thing that changed was that the CU was left out.

Since it's not really good to be running SharePoint without any CU, I read Stefan Goßner's blog to find a CU that didn't have comments about things being broken. I chose September 2019 CU and tried to install it next. I deleted the search service and created a new one, and now one of the farms does find crawled properties, but the other one doesn't. I've been through every setting I can think of and can't find any differences between these two farms. What am I missing?

During all these tests, I noticed rights for the search service application db keep dropping as described in this blog post. Because of that I always create the search service application from Central Administration first, and then use DSC to add content sources etc. However, that hasn't helped, and the rights continue being dropped each time the administrators are changed. I always add them back in, but it doesn't change how the crawled properties work. All rights are set up like best practices say, so have no idea what is wrong.

Has anyone else had similar issues? Do you have any ideas what I could try next?

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,297 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,898 questions
0 comments No comments
{count} vote

Accepted answer
  1. elephantballoon 106 Reputation points
    2021-04-20T12:12:05.697+00:00

    To inform everyone, this was a combination of three things:

    1. Basically any CU up until and including February 2021 didn't work. When I installed the March 2021 CU, some of the properties started appearing, but not all.
    2. For a while we had a faulty solution that broke authentication. I removed it (and any traces), which of course helped. This wasn't a cause, but got me sidetracked for several days.
    3. To get the last few properties to work (specifically: publishing start date, publishing expiration date, photographer on one image gallery list, some metadata columns), I had to set the crawling account as a secondary site collection administrator. This is in line with the problems in the cloud version, where you needed to set site collection administrators in order to get some sites to work.

    For everyone concerned about which updates I installed, this farm is not in production. My task was specifically to find a way to have the latest updates AND have search work (which didn't seem possible for a long time). I'm both dreading and interested to see what this month's updates bring, as I am currently installing them. Maybe there's a fix for the site collection admin bug, or maybe something else gets broken again...

    (By the way, thanks Trevor for your posts on SharePoint issues. Several of them have been useful during this project, though mainly not on this specific issue.)

    1 person found this answer helpful.
    0 comments No comments

6 additional answers

Sort by: Most helpful
  1. sadomovalex 3,631 Reputation points
    2021-03-18T15:04:00.467+00:00

    I would try these steps in such situation:

    • remove search service app
    • install latest available CU for SP2019
    • create search service app (when CU is already installed)
    • configured content sources and performed Full crawl

  2. Emily Du-MSFT 44,311 Reputation points Microsoft Vendor
    2021-03-19T08:14:52.137+00:00

    @elephantballoon
    Could you get the correct search results when using search? Did you set crawl rules in the search service application?

    1.After installing CU, you should run SharePoint 2019 Products Configuration Wizard.
    2.Go to Central Administration -> Manage service applications -> Search Service Application -> Check whether any error messages on the search administration page. And the default content access account has full read permission for the web application.
    3.Check the ULS logs to find more clues.

    If the issue persists, I suggest you open a ticket with Microsoft. It’s the fast way to resolve your issue.


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  3. Trevor Seward 11,696 Reputation points
    2021-03-19T18:18:28.403+00:00

    Have you noticed a difference with columns which have had data add to them via List/Library (i.e. attach the column to a List, create a List Item with data in that column) versus columns which have been created for which there is no data associated with them?

    You should always remain on the latest Public Update for security purposes. Also keep in mind the servicing support policy:

    https://learn.microsoft.com/en-us/sharepoint/product-servicing-policy/updated-product-servicing-policy-for-sharepoint-2019

    0 comments No comments

  4. SARTEEL Christophe 1 Reputation point
    2021-05-27T14:13:21.787+00:00

    Hi
    I have exactly the same problem on my SP2019 On Premise Farm. Some crawled properties are not created even if I already :

    • Set the Farm Admin as crawled account (for the test)
    • Reset the index
    • Create new site columns
    • Add the existing site columns in a new list, put some data and recrawled
    • Applied last CU (April 2021) + wizard + full crawl...
    • ...

    I've a standard 4 server farms with MinRole applied. So nothing exotic...

    I'm lost, but very annoying because we are using extensively the search and mapping a managed property to a crawled property is required for a lot of business scenario.

    There is definitevely something wrong....

    0 comments No comments