Hi team, I can't see create inference pipeline in my top pane beside submit button on Azure ML designer

Geethesh 11 Reputation points
2021-03-19T09:31:10.477+00:00

![79621-free-trail-designer.png][1] [1]: /api/attachments/79621-free-trail-designer.png?platform=QnA

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
2,723 questions
0 comments No comments
{count} votes

4 answers

Sort by: Most helpful
  1. kikea 116 Reputation points
    2022-05-20T02:12:54.987+00:00

    For all those who are having this same issue: it happened to me that, suddenly, the pipeline design page changed and, after this, the pipelines modules weren't and couldn't be sorted by type:

    How it was before the change (according to Msft doc https://learn.microsoft.com/en-us/azure/machine-learning/tutorial-designer-automobile-price-train-score):

    203941-design-pipeline-old.png

    How it is now after the change:

    203845-design-pipeline-new.png

    Other consequence of the change was that the top right button 'Create inference pipeline' dissappeared:

    How it was before the change (according to Msft doc https://learn.microsoft.com/en-us/azure/machine-learning/tutorial-designer-automobile-price-deploy):

    203893-inference-pipeline-old.png

    As consequence, after this sudden change, in order to be able to deploy a no-code machine learning model in Azure you have to go to the 'jobs' page and there you can find the 'Create inference pipeline' drop-down list:

    203933-inference-pipeline.png

    It's a shame that after one year, no one in Microsoft have been able to answer this question satisfactorily and to solve this problem that, furthermore, is 'magically' generated by Azure from one moment to another... A lot of wanting to promote the no code tool but afterwards, when people get stucked (normally not deep tech people), no help at all.

    Hope this answer can help to those who were lost like me.

    18 people found this answer helpful.

  2. TrueType 65 Reputation points
    2023-07-26T18:02:53.9433333+00:00

    I found this to be a WebBrowser issue with mine. The "Create inference pipeline" button was first hidden behind the three dots (...) but when I clicked on "Create inference pipeline" nothing happened.. no dropdown. I tried all advice I had seen and then I remembered a WebBrowser (Edge in my case) 'feature'. Using Ctrl and minus (Ctrl -) to 'Zoom Out' brought all buttons onto the page and the 'Create inference pipeline' dropdown appeared and started working.

    Hope this helps some cases

    12 people found this answer helpful.

  3. Matthew Beattie 26 Reputation points
    2021-05-13T22:53:23.45+00:00

    I have the same problem

    5 people found this answer helpful.
    0 comments No comments

  4. romungi-MSFT 43,696 Reputation points Microsoft Employee
    2021-03-19T14:33:08.65+00:00

    @Geethesh Could you please try to submit the pipeline and then check if the option to deploy real time inference pipeline is available.

    2 people found this answer helpful.