WebBrowser control not in toolbox

richard markham 26 Reputation points
2021-03-20T11:30:51.48+00:00

Simple question: The WebBrowser control is shown in the list of tools checked, but it's not visible in the toolbox?

Windows Forms
Windows Forms
A set of .NET Framework managed libraries for developing graphical user interfaces.
1,869 questions
0 comments No comments
{count} vote

Accepted answer
  1. Castorix31 83,101 Reputation points
    2021-03-20T12:15:32.07+00:00

    If I create a C# project in Winforms (.NET Framework 4.7.2) , it is in the Toolbox in "All Windows Forms" controls =>

    79852-webbrowser-toolbox.jpg


3 additional answers

Sort by: Most helpful
  1. richard markham 26 Reputation points
    2021-03-20T13:02:08.877+00:00

    OK, I found it. I was not creating a .NET Framework app.

    0 comments No comments

  2. Keith Sheppard 1 Reputation point
    2021-11-07T15:52:11.743+00:00

    I have decades of experience with VB and Visual Studio vn6 but a rank beginner the dot net version. Please excuse any naive questions. I am also unable to add a WebBrowser control to my form.

    What do you mean, @richard markham , when you said "I was not creating a .NET Framework app"? When I created the project, I chose "Windows Forms App (A project template for creating a .NET Windows Forms (WinForms) app". Was this the wrong choice? I tried WPF Browser App but whatever the Wizard created, it didn't even compile. I notice further down the list there's an Empty Project option that mentions .NET framework but that (presumably) doesn't give me the forms bit. How do I create a .NET Framework forms app?

    By the way, I tried dynamically adding a web browser in code, but that did nothing.

    All I want is a simple app whose window includes a browser control. Is that so hard to ask? I would rather do it in C++ but the only forms app I can find is VB-only. I can live with that but why no Web Browser control in the toolbox?

    0 comments No comments

  3. richard markham 26 Reputation points
    2021-11-07T17:44:41.037+00:00

    Hi Keith, I'm in the same boat!

    I have no idea why somethnig so simple has to be so awkward!

    IIRC I had to select Windows Forms App (.NET framework) Visual basic template when I created the new project. Selecting just Windows Forms App didn't bring the webpage tool into the toolbox and no amount of faffing about would get it to show up.