Cannot save changes to rules engine when using rule with the "Any" operator

asked 2020-06-05T16:08:05.023+00:00
Evan Mulawski 1 Reputation point

When saving rules via the Rules Engine, a recent Azure backend change has resulted in an error being returned when using the "Any" operator for a rule. My last successful save was Fri May 22 2020 15:01:51 GMT-0400 (Eastern Daylight Time), so the issue was introduced after this time. When will this be resolved?

Related: https://social.msdn.microsoft.com/Forums/en-US/5a3e9cd7-4fe1-4962-9ec4-2da4266c2d56/deployment-issues-with-arm-template-number-of-elements-within-the-collection-are-not-within-the?forum=azurecdn

Error message:

BadRequest: The number of elements within the collection 'Endpoint.DeliveryPolicy.Rules[2].Conditions[0].Parameters.MatchValues' are not within the minimum and maximum acceptable range for number of elements [1-10]

9138-capture.png

CDN Tier: Microsoft (S3)

Azure Content Delivery Network
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2020-06-08T07:20:05.677+00:00
    Subhash Vasarapu 9,846 Reputation points

    Greetings,

    Our team is aware of this bug and they are working on mitigating the bug for permanent solution and they do not have an exact ETA for us.
    So, the current workaround is not to use any/not any operator and use other operators to construct always true condition.

    Apologies for the inconvenience caused and thank you in advance for understanding.

    No comments