question

AbdulSaifBabu-7422 avatar image
0 Votes"
AbdulSaifBabu-7422 asked MichaelHan-MSFT answered

SharepointOnline site properties are not updated through REST API

Upon updating Sharepoint Online site properties(eg., title, description) through REST API, the updated values don't reflect until site information page is manually accessed.
Update site properties is working fine for SPOnpremise but not for SPOnline

Steps:
1. Update site properties (title/description) through REST API
2. Get the site properties via REST/UI. It can be now observed that properties are not updated
3. Access site via browser and click on site settings - site information
4. The new properties are displayed here.
5. Now repeat step 2, and the updated values are reflected now.

While working with REST, it is not expected that user would access SPO via browser to get these properties reflect rightly.
Please refer screenshots
80261-1.png80226-2-after-rest-update.png80179-3-accessing-site-info.png80214-4-refreshed-again.png


office-sharepoint-online
1.png (63.4 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MichaelHan-MSFT avatar image
1 Vote"
MichaelHan-MSFT answered

Hi @@AbdulSaifBabu-7422,

The endpoint you used is to update the title and description of the group. After you updated the group, you need to wait some time to sync the title and description to site. Per my test, it costs about 2 hours.

To make the change get reflected in the site immediately, you could call this API call to sync:

 /_api/GroupService/SyncGroupProperties

83443-image.png



If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (15.5 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

MichaelHan-MSFT avatar image
0 Votes"
MichaelHan-MSFT answered AbdulSaifBabu-7422 edited

Hi @AbdulSaifBabu-7422,

Per my test, updating site properties through REST API is working fine on my tenant. The updated values will normally reflect.

Please check the below to troubleshoot this issue:

  • Could it be related to the browser cache ? After updating Sharepoint Online site properties, try to clear the cache (or in private mode). Check the results.

  • Did this issue exist in other sites? Or just this site. Please try to do some test on other sites. Check if the the same issue happens.


If an Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks for response @MichaelHan-MSFT, we did initial troubleshooting and it is occuring for all our online sites. Everytime site properties update is hit, its returning successful response but the latest values are not reflecting.

0 Votes 0 ·

Here are the details, Please find the endpoint we are using and the request body. It is same behavior for all the sites.82645-1.png82623-2.png


0 Votes 0 ·
1.png (94.3 KiB)
2.png (61.6 KiB)