question

Si-0828 avatar image
0 Votes"
Si-0828 asked ajkuma-MSFT commented

Custom domain empty for SSL/TLS binding.

In Azure web app, I have imported an app service certificate and it displays in the list. I then try and add a TLS/SSL binding but the Custom Domain dropdown list is empty. Any idea why that is?

azure-webapps-ssl-certificates
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

@Si-0828, Thanks for the question!

As I understand from your question, you have gone through the steps from this section ‘Import certificate into App Service’ and now trying to Create the binding.
To assist you better, could you post a screenshot of the issue after concealing any private information?

If you haven’t done this already, you may refresh the browser session/ ensure that you’re on the right WebApp/subscription directory.

Have you added and mapped the domain (as per this doc)?
-If the domain and the app are in different subscriptions, you map the App Service domain to the app just like mapping an externally purchased domain.

0 Votes 0 ·

1 Answer

ajkuma-MSFT avatar image
1 Vote"
ajkuma-MSFT answered ajkuma-MSFT commented

@Si-0828, Adding more info:

In the Azure Portal, go to your web app and navigate to the “Custom domain” section under “Settings”. Look for the domain you want to secure from the list of “Assigned Custom Domains” and click “Add binding”.

See, Tutorial: Map an existing custom DNS name to Azure App Service
And, just to confirm, did you purchase App Service domain or App Service Managed domain?

Kindly see the different between App Service Certificate and App Service Managed Certificate – each of these certificates can be used for different requirement:
https://microsoft.github.io/AzureTipsAndTricks/blog/tip259.html

Kindly let us know how it goes, I'll follow-up with you further. Thanks for your patience!

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Thanks, that was it - all sorted.

1 Vote 1 ·

@Si-0828, Glad to know that the issue is resolved. Thanks for the update.

To benefit the community find the right answers, please do mark the post which was helpful by clicking on ‘Accept Answer’ & ‘Up-Vote’.

1 Vote 1 ·