Visual Studio How can I enable editing tabs?

slipbits 6 Reputation points
2021-03-25T16:45:56.35+00:00

I was modifying some options int Tools->Options and accidentally turned off all editing tabs. When I press the <tab> button, not space is inserted. I've tried to reset formatting and done other strange and wonderful things but, not tabs. How can I enable tabs?

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
2,426 questions
Visual Studio Setup
Visual Studio Setup
Visual Studio: A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
698 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Castorix31 65,711 Reputation points
    2021-03-25T16:56:42.79+00:00

    You can check in

    Tools
    Options
    Text Editor

    Choose the language (or "All Languages")
    then

    Tabs

    No comments

  2. Dylan Zhu-MSFT 6,346 Reputation points
    2021-03-26T05:28:42.917+00:00

    Hi slipbits,

    You can check if the "smart" has been selected, and "insert spaces" has been enabled.
    81781-image.png

    In addition, if you are using editconfig file, please check if the indent_size is not zero.
    81716-image.png

    Best Regards, Dylan

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our * *documentation* to enable e-mail notifications if you want to receive the related email notification for this thread.**

    No comments