Visual Studio GIT broken

Heinrich Ludike 121 Reputation points

I have recently run into a serious little issue on my Visual Studio 2019 Community Edition.

I cannot fetch, pull or push my repo, it had an issue with my CA-bundle.crt. I tried a few things on GIT, tried pointing it to the correct certificate but to no avail.
Uninstalled my entire Visual Studio, renamed my project and tried to clone a fresh repo. This was met with more failure.

Git failed with a fatal error.
unable to access "": error setting certificate verify locations: CAfile: C:/Program Files/Git/mingw64/ssl/certs/ca-bundle.crt CAPpath: none

I looked at the location and no file was located there, I found another ca-bundle.crt under C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\CommonExtensions\Microsoft\TeamFoundation\Team Explorer\Git\mingw32\ssl\certs which I then copied to the location. This did not resolve the issue either.

Any idea how to fix this? Or any other possible solution?

Visual Studio
Visual Studio
A family of Microsoft suites of integrated development tools for building applications for Windows, the web and mobile devices.
4,440 questions
0 comments No comments
{count} vote

3 answers

Sort by: Most helpful
  1. Dylan Zhu-MSFT 6,396 Reputation points

    Hi HeinrichLudike,

    It seems that there is something wrong about the configuration of your github tool. You can go to Extension/Manage Extensions to re-install github extension.
    Best Regards,

    If the answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our **documentation to enable e-mail notifications if you want to receive the related email notification for this thread.**

    1 person found this answer helpful.
    0 comments No comments

  2. Ken Tucker 5,841 Reputation points

    try installing the latest version of git for windows

  3. Todd Bandrowsky 1 Reputation point

    See this link:

    There seems to be an issue with VMWare Horizon Agent breaking the git named pipe support.

    0 comments No comments