Kms licence info lost, enterprise reverts to pro

Erik Wold 1 Reputation point
2021-03-26T18:05:00.157+00:00

Windows 10 2004 Feature upgrade through SCCM Hi, a couple of months back I tested Feature upgrade from 1809 to 2004 with sccm and it worked as expected, also over DirectAccess. Now when we are rolling this out something strange occures: KMS licensing information is lost and the PC reverts to Pro with a digital license, and this of course is bad since DA no longer works. What I also saw with one client that was reinstalled in february with 2004 was that KMS licence info we're lost when the latest cumulative update ran. Anyone else seen this?

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
5,941 questions
Windows 10 Setup
Windows 10 Setup
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Setup: The procedures involved in preparing a software program or application to operate within a computer or mobile device.
1,730 questions
{count} votes

4 answers

Sort by: Most helpful
  1. Erik Wold 1 Reputation point
    2021-03-27T16:21:07.25+00:00

    The kms server can be pinged as long as DA is enabled (before the upgrade, worked for years with every upgrades). The issue is that during the upgrade the kms info is gone and after reboot the pc is activated with the embedded pro license and then DA is not working (DA is only for enterprise), so the pc can no longer reach the kms server since DA is not available on the pro SKU. Will try to look at the event log when I get hold of a client.


  2. Jenny Feng 13,666 Reputation points
    2021-03-29T03:08:10.227+00:00

    @Erik Wold
    Hi,
    Does manual upgrade also cause this problem?
    Di you mean the KMS Host key was lost during the upgrade?
    Di you use Windows 10 Enterprise subscription?

    Try to reinstall the KMS host key on the KMS host to see if the issue will be solved.
    slmgr /ipk xxxxx-xxxxx-xxxxx-xxxxx-xxxxx

    Hope above information can help you.

    ============================================

    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

  3. Erik Wold 1 Reputation point
    2021-03-29T06:36:53.643+00:00

    I have a feeling that someone might have changed the licenses for some users to Microsoft E license and not ticked off for Enterprise. It will take some time to confirm this and since this haven't affected all users I'm not sure.

    Does manual upgrade also cause this problem?
    Not on my test user
    Di you mean the KMS Host key was lost during the upgrade?
    Yes. KMS was cleared
    Di you use Windows 10 Enterprise subscription?
    We didn't before but someone might have changed the license


  4. Erik Wold 1 Reputation point
    2021-03-30T09:10:54.557+00:00

    Thanks @Jenny Feng . Yes, and this might be the case. The org. hasn't confirmed yet if they have changed the licenses for their users, originally they used to have Office E3 and EMS licence but I have a feeling they might have changed this recently.

    No comments