question

SeuliDasMajumder-3800 avatar image
0 Votes"
SeuliDasMajumder-3800 asked KranthiPakala-MSFT commented

Failed to connect to ADLA account 'XXXXXXXXX' with error 'Operation returned an invalid status code 'NotFound''. Operation returned an invalid status code 'NotFound'

Trying to create ADF pipeline to execute an USQL script. For this it is required to create a linked service to my data data lake analytics account.

to create the linked service we need to provide service principal id and key. for that I did an app registration in active directory and also give access to my strorage account.

Following all these required steps, still getting error like below:

Failed to connect to ADLA account 'XXXXXXXXX' with error 'Operation returned an invalid status code 'NotFound''. Operation returned an invalid status code 'NotFound'.

Can anyone please highlight what be the possible reason behind this issue

azure-data-factoryazure-storage-accounts
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

KranthiPakala-MSFT avatar image
0 Votes"
KranthiPakala-MSFT answered KranthiPakala-MSFT commented

Hi @SeuliDasMajumder-3800,

Welcome to Microsoft Q&A and thank you for your query.

Could you please make sure Microsoft.DataLakeAnalytics resource provider is registered in your subscription.

  1. Go to the Subscriptions in Azure portal and then click the subscription which you are using.

  2. Click Resource Providers under Settings.

  3. Search for Microsoft.DataLakeAnalytics as below and if it’s not registered then click register.

    9411-adlaresourceprovider.png


Do let us know if you are still facing the issue.



Thank you

Please do consider to click on "Accept Answer" and "Up-vote" on the post that helps you, as it can be beneficial to other community members.





· 8
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I have the exact same issue.
I've confirmed it's not a service principal/key issue by putting in a bad key then testing the connection. In this test, I get a different error.
When I use good creds, I get the same NotFound error.

Per your suggestion, I've checked the Subscription / Resource providers and Microsoft.DataLakeAnalytics IS registered.

Any other ideas/thoughts?

0 Votes 0 ·

I have the very same issue. When creating linked service I get the error:
Failed to connect to ADLA account 'XXX' with error 'Operation returned an invalid status code 'NotFound''. Operation returned an invalid status code 'NotFound' Activity ID: ....

What is actually the ADLA account - is it the name of Azure Data Lake Analytics resource? Or is the name of app registration used as service principal?

0 Votes 0 ·

Thanks for your response. I have checked following your steps, but it is registered.

0 Votes 0 ·

I have checked the issue further and there is similar issue reported here:

https://docs.microsoft.com/en-us/answers/questions/32430/api-version-wrong-when-creating-linked-service-for.html

Is it a bug in creation of linked service to Azure Data Lake Analytics? When it will be fixed - June 2020?

I need to execute U-SQL scripts from Data factory and linked server creation problems are blocking me.

Thank you for info.

0 Votes 0 ·

Hi @JunekPetr-2764,

Apologizes for the delay in response. The other issue link you have shared is related to test connection issue, and was fixed on 6/12/2020. Could you please confirm if you are still experiencing the issue?



Thank you

1 Vote 1 ·
Show more comments