question

NikolaiMelekhin avatar image
0 Votes"
NikolaiMelekhin asked NikolaiMelekhin commented

We can't show MailTips right now after migrating

Hello. We had Exchange 2016 RTM and decided to migrate to Exchange 2016 CU20. Everything is looking okay but when we migrate mailboxes to new server, to new database, user sees "We can't show MailTips right now" when he starts new message in Outlook. OWA works fine. I've tried everything i've found here to fix it, but still nothing. Interesting facts: if I migrate mailbox back to the old database, message disappears. Another thing: if I create new mailbox directly to new server and database and use clean outlook client, the message appears. Ideas?

office-exchange-server-mailflow
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

And the weirdest thing: if I create new mailbox on the new server in the new database and the migrate it to the old server - message will disappear!

0 Votes 0 ·
NikolaiMelekhin avatar image
0 Votes"
NikolaiMelekhin answered NikolaiMelekhin commented

Using Get-OrganizationConfig I found
EwsApplicationAccessPolicy : EnforceAllowList
EwsAllowList : {SkypeSpaces/, Teams/, MicrosoftNinja/}

Their local admin said they are using Skype and Teams, azure AD.

So, setting EwsApplicationAccessPolicy to default (which is $null) solve the problem with MailTips &Co but started problems with using Skype

· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @NikolaiMelekhin ,
Thanks for sharing the detailed solution, this will help more users who have the same issue.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


0 Votes 0 ·

Some more information: There is the same parameter in ADUC in User Attributes.
Problems with cloud-skype were caused by existing the same parameter in attributes. Setting it to null as well will solve the rest of problems.

0 Votes 0 ·
AndyDavid avatar image
0 Votes"
AndyDavid answered

I'd give it time. MailTips take time to build up.
https://techcommunity.microsoft.com/t5/exchange-team-blog/troubleshooting-mailtips/ba-p/596073

If all else fails, restart IIS after you move all the mailboxes once its complete.

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

LucasLiu-MSFT avatar image
0 Votes"
LucasLiu-MSFT answered LucasLiu-MSFT edited

Hi @NikolaiMelekhin ,
Agree with what Andy said. The MailTips depend on EWS service, so please make sure that Autodiscover services and EWS service work normally, you could also do the following steps:
1.Please hold the “Ctrl” and right-click the Outlook icon, then select the “Test E-mail AutoConfiguration” to test the autodiscover.
82599-image.png

2.Please run the following command to verify that the EWS URL and auth method are set correctly. And compare whether the authentication method settings in the old server and the new server are the same. If they are different, please try to change them to the same. then restart the IIS to make the changes take effect. And the following picture is the default set in my Exchange 2016 environment.

 Get-WebServicesVirtualDirectory | fl *url*,*auth*

82565-image.png

3.Please try to test autodiscover service and EWS service by using ExRca: Microsoft Remote Connectivity Analyzer , If something goes wrong, the report it provides may help us solve the issue.



If the response is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



image.png (9.3 KiB)
image.png (16.9 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

NikolaiMelekhin avatar image
0 Votes"
NikolaiMelekhin answered

HI @LucasLiu-MSFT
Thank you for advises! 1 and 2 shows similar information for both mailboxes (the one in old db and another in the new)

Connectivity Analyzer returned success for old server (testing mailbox in the old db on the old server)
But failure for the new server. Results:

Exchange Web Services synchronization, notification, availability, and Automatic Replies.
Not all tests of Exchange Web Services tasks completed.
Test Steps

The Microsoft Connectivity Analyzer is attempting to test Autodiscover for infotest@mydomain.ru.Autodiscover was tested successfully.
Test Steps

Creating a temporary folder to perform synchronization tests.
Failed to create temporary folder for performing tests.
Additional Details
Exception details:

Message: The request failed. The remote server returned an error: (403) Forbidden.

Type: Microsoft.Exchange.WebServices.Data.ServiceRequestException
Stack trace:
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.ValidateAndEmitRequest(IEwsHttpWebRequest& request)
at Microsoft.Exchange.WebServices.Data.MultiResponseServiceRequest`1.Execute()
at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder(FolderId folderId, PropertySet propertySet)
at Microsoft.Exchange.WebServices.Data.ExchangeService.BindToFolder[TFolder](FolderId folderId, PropertySet propertySet)
at Microsoft.M365.RCA.ConnectivityTests.GetOrCreateSyncFolderTest.PerformTestReally()

Exception details:
Message: The remote server returned an error: (403) Forbidden.
Type: System.Net.WebException
Stack trace:
at System.Net.HttpWebRequest.GetResponse()
at Microsoft.Exchange.WebServices.Data.EwsHttpWebRequest.Microsoft.Exchange.WebServices.Data.IEwsHttpWebRequest.GetResponse()
at Microsoft.Exchange.WebServices.Data.ServiceRequestBase.GetEwsHttpWebResponse(IEwsHttpWebRequest request)

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.