Installing missing frameworks... forever with Framework Microsoft.NET.CoreFramework.Debug.2.2/X64 Microsoft.VCLibs.140.00.Debug/X64 is NOT installed

SmilingMoon 976 Reputation points

After upgrading VS version yesterday, when I deploy UWP project it hangs on "Installing missing frameworks..." for already 5 hours.

Restarted computer & VS multiple times, VS repair, changed minimum target to latest, updated all nuget packages, nothing works.

Creating a new clean layout...
Copying files: Total 21 mb to layout...
Checking whether required frameworks are installed...
Framework: Microsoft.NET.CoreFramework.Debug.2.2/X64, app package version 2.2.28529.0 is not currently installed.
Framework: Microsoft.VCLibs.140.00.Debug/X64, app package version 14.0.27810.0 is not currently installed.
Installing missing frameworks...

My VS version is:
Microsoft Visual Studio Enterprise 2019
Version 16.6.1

Everything worked fine until upgrading VS.
Please help.

Universal Windows Platform (UWP)
0 comments No comments
{count} votes

Accepted answer
  1. SmilingMoon 976 Reputation points


    NichoZhu~, thank you for your answer. The issue has been resolved by itself before I saw your answer.

    Here is how it's been fixed.

    I left the computer overnight after "Deploying." with the following message.
    " Installing missing frameworks..."

    Today, it's been fixed. It seems VS did its job. => Someone can tell me "Be more patient" :)

    Waiting for few hours for the command line output while deploying is, I think, good amount of patient.
    If it takes hours or days of task that must be done, that must be checked and done in VS upgrade. Or additional message or help must be provided.
    No developer can think of waiting that long while compiling and deploying app that used to work well after VS upgrade.

    This is the pain and trauma for us think many times and tries to avoid VS upgrade.
    (I postpone upgrade weeks actually, and again ended up this VS upgrade problem again.)
    => I wish VS team do better job for upgrade although they have excuse.

    Thank you!

    1 person found this answer helpful.
    0 comments No comments

5 additional answers

Sort by: Most helpful
  1. Nathan 11 Reputation points

    I am also experiencing this, after updating last week to the latest version of VS 2019. However, after updating, both VS 2017 and VS 2019 now experience this hang when trying to deploy any UWP app. I also tried completely uninstalling both VS 2017 and VS 2019 and reinstalling only VS 2019 and still had the same issue.

    I tried the fix mentioned by @NavtejSaini-MSFT by installing the appx manually, but even those installations seem to hang at 10%, which I suspect is happening the same within Visual Studio.9936-annotation-2020-06-15-100522.png. I can let it sit for hours and it doesn't get past 10% progress.

    At this point I'm completely unable to deploy any app from VS for nearly a week now. Any help would be appreciated.

    1 person found this answer helpful.

  2. Nathan 11 Reputation points

    After banging my head against the wall over this for a week I finally resorted to resetting Windows (keeping personal files and app data) the problem was 'fixed'. I don't want to say it was fixed because having to reinstall Windows isn't a fix for anything. But, if you're having this issue, resetting Windows might work for you.

    1 person found this answer helpful.
    0 comments No comments

  3. Nico Zhu (Shanghai Wicresoft Co,.Ltd.) 12,826 Reputation points

    Welcome to Microsoft Q&A,

    Derive from the error info, it looks that you miss install Microsoft.NET.CoreFramework.Debug and Microsoft.VCLibs.140.00.Debug app decencies, you could install them manually,

    please navigate to this path C:\Program Files (x86)\Microsoft SDKs\UWPNuGetPackages\\2.2.10\tools\Appx\ then find the missed appx and reinstall, if the app installer tell you current appx could not be install, please skip above steps then download .NET Core 2.2 windows sdk and reinstall.


    Nico Zhu

    0 comments No comments

  4. John Linstrum 1 Reputation point

    I had the identical issue and I did a clean install of Windows, moved over all my source code, etc. and the problem went away as well. In my case it was a good opportunity to upgrade my main drive, but it seems like a lot of work just to fix whatever this is. One would think there should be some other way of cleaning out the source of the problem.

    Also I wonder if the issue is due to something new in VS 2019 release 16.6, or if it has to do with the Blazor/wasm/.Net core 3.1 bleeding edge development I've been doing on the same machine? If the latter, I'm dreading when I have to reinstall the SDKs etc. for my Blazor project.

    0 comments No comments