DNS error after Windows 10 20H2 upgrade

Peter 111 Reputation points

After upgrade to Windows 10 version 20H2 internet connection was gone and “Hello” function couldn’t turn on camera. Rolled back upgrades and everything worked fine again on previous OS release. 10 days later, I performed upgrade a second time with same result: No internet access.

After a few minutes, the laptop connects to Wi-Fi and I can connect and login to the router. I can successfully ping IP addresses ( or or I cannot ping URLs and get no Outlook connection. All other devices on this router/ISP work fine. I tried it on two different router/ISP configurations. The problem is with the laptop configuration after the upgrade. The OS upgrade itself completed without any issues both times.

Perhaps the most telling observation is the result of the ipconfig /registerdns command: “Registration of DNS records failed: The configuration registry key is invalid.”

Laptop: HP Spectre X360 (core i7)

No idea how to fix this after all I tried (see below)! Your insights are much appreciated.

What I tried to fix connectivity issue


Running windows trouble shooter: “Your DNS server might be unavailable” (when I ran it at other times I got “Couldn't identify the problem”)

Rebooted router (despite the fact that all other devices on network are working as expected)

Checked HOSTS file: no entries

From: https://www.hp.com/us-en/shop/tech-takes/how-to-resolve-dns-issues
ipconfig /flushdns --> ok
Ipconfig/registerdns --> results in error message: “Registration of DNS records failed: The configuration registry key is invalid.”
ipconfig /release --> ok
ipconfig /renew --> ok
NETSH winsock reset catalog --> ok
NETSH int ipv4 reset reset.log --> ok
NETSH int ipv6 reset reset.log --> ok

From: https://learn.microsoft.com/en-us/answers/questions/124300/still-not-fix-no-internet-connection-bug-in-window.html

  1. sfc /scannow --> ok
  2. DISM /Online /Cleanup-Image /RestoreHealth --> ok
  3. [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet] EnableActiveProbing set to 1 --> ok
  4. [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator] NoActiveProbe set to 0 --> ok
  5. [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\NetworkConnectivityStatusIndicator] DisablePassivePolling set to 1 --> registry entry not present

nslookup: doesn’t return any results (also no error message)

Windows DHCP
Windows DHCP
Windows: A family of Microsoft operating systems that run across personal computers, tablets, laptops, phones, internet of things devices, self-contained mixed reality headsets, large collaboration screens, and other devices.DHCP: Dynamic Host Configuration Protocol (DHCP). A communications protocol that lets network administrators manage centrally and automate the assignment of Internet Protocol (IP) addresses in an organization's network.
994 questions
0 comments No comments
{count} vote

Accepted answer
  1. Peter 111 Reputation points

    After a few more hours of trying and digging, I'm happy to report that I was able to fix the issue (at least it appears that way). Here is how:

    From: https://www.hp.com/us-en/shop/tech-takes/how-to-resolve-dns-issues
    7. Change to public Google DNS servers
    Google’s servers are often more reliable and can be used without going through your ISP. You can change your DNS servers to Google’s by changing your Internet Protocol Version 4 (TCP/IPv4) properties:

    1. Click on the internet icon in your task tray to bring up your available networks. Click on Network and Internet Setting link.
    2. Click Change Connection Properties or Change Adapter Settings.
    3. In the new window, right-click on the connection you are using. Select Properties.
    4. Choose Internet Protocol Version 4 (TCP/IPv4) from the list, and click the Properties button.
    5. Choose Use the following DNS server address option.
    6. Type into the Preferred DNS server fields.
    7. Type into the Alternate DNS Server fields.
    8. Click OK to save and exit the TCP/IPv4 window. Click OK to save again to exit the Properties window.

    Once everything was connected the ipconfig /registerdns command ran successfully. I was able to switch back to automated DNS addresses without losing connectivity.

    2 people found this answer helpful.

3 additional answers

Sort by: Most helpful
  1. Dean 21 Reputation points

    If changing the DNS provider does solve this issue then open up

    Find a key named "SearchList", if it is a zero length binary then delete it and DNS lookups will be restored.

    4 people found this answer helpful.

  2. Cor Hofstee 6 Reputation points

    Go to the registry and find below key:

    Find the key with name ‘start’and change from 4 (disabled) to 2 (automatic). That will help 100%!

    1 person found this answer helpful.

  3. Dave Patrick 417.4K Reputation points MVP

    Spectre X360 is untested so may be unsupported as of this document.

    --please don't forget to Accept as answer if the reply is helpful--

    0 comments No comments