question

57368608 avatar image
0 Votes"
57368608 asked 57368608 answered

Visual Studio 2019 Error - "External component threw an exception"

Hello I am having a problem with VS2019.

After installation, I ran the application and got the error "external component threw an exception".

I wrote to the support service and searched the Internet but found nothing.
All updates are installed and I meet the system requirements. ( I have Windows 7 SP1 )

Please, help me!

vs-general
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @57368608 , welcome to Microsoft Q&A forum.

Need to confirm something with you.

1). Did this error appear after you chose and created a project or after you clicked and launched VS 2019 before you selected the project template?
2). Are there other detailed information reported by VS?
3). Did you install some antivirus software of applications which may prevent VS from running?(If yes, I suggest you disable them temporarily and run VS to try again)

Suggestion:

Currently, please try to run VS as administrator.

Besides, please run Developer Command Prompt for VS 2019, and type devenv.exe /log, then try to reproduce this issue and close VS after the error appears, after that please share me the ActivityLog.xml file(usually under %AppData%\Microsoft\VisualStudio\16.0_<UniqueID>) to check further.(please use the Attachment button to attach the xml file.)
83703-image.png


0 Votes 0 ·
image.png (7.5 KiB)
TianyuSun-MSFT avatar image
0 Votes"
TianyuSun-MSFT answered

Hi @57368608 ,

Thank you for sharing me the log file.

I have checked the log file, there isn’t any error message but a warning ”source: MruPackage. Description: About to block on async service creation because the service was requested via GetService. This has the potential to deadlock. Async initializing services should be retrieved via GetServiceAsync.”

What kind of workloads and components did you install?

Please try to run Developer Command Prompt for VS 2019, type devenv /SafeMode to run VS and let me know if this issue disappear. Besides, please repair VS in VS Installer > VS 2019 > More > Repair.

Best Regards,
Tianyu


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

57368608 avatar image
0 Votes"
57368608 answered

Thank you very much! I repair VS2019 and it worked! Thank you!

5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.