question

JRFM-8055 avatar image
0 Votes"
JRFM-8055 asked saldana-msft edited

Graph Explorer Token vs App only or user based

Hi, I am wondering what the discrepancy is between the graph explorer access token and the token I am retrieving using postman & my .NET web api.

When using the Graph explorer I am unhindered when running queries. However, when I use the same user/password on postman suddenly those queries do not work.

I have used jwt.ms to look at the token scopes/permissions and the tokens I retrieve from postman have all permissions and more. I have also consented to the permissions on Azure.

Many of the queries I run on postman work but the moment I do a POST such as where I am trying to add a folder to a SharePoint site, I only receive a Bad Request with the message Invalid request; however, grab the token from the Graph Explorer and use it to make the same request in postman and everything works fine.


The query is as so: https://graph.microsoft.com/v1.0/sites/{siteId}/drives/{driveId}/root/children HttpMethod: POST

I have dug around the ms docs but cannot seem to figure out why only the graph explorer access token works.

I have tried with an App-only access token (the preferred choice). I have tried on behalf of the user.

The only impediment is the Access Token.

Additionally, the company admin IT himself has no answers and has not been able to help. We are both puzzled.

I appreciate all or any help.

microsoft-graph-sdkmicrosoft-graph-files
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Adding right tags/teams to assist

0 Votes 0 ·

Please provide details of how you acquire the access token using Postman with the scopes requested. If you are using application permissions provide the scopes added to the applications in AAD.

Also the full error message can help understand what is going wrong. One of the required permissions as listed here but be present. Can you share the difference between the scopes/roles you see in jwt.ms


0 Votes 0 ·

0 Answers