How to adjust virtual machine display resolution to adapt to full screen

yzgoa 1 Reputation point
2021-04-01T23:16:13.827+00:00

I've used VirtualBox before, and am new to Hyper-V.

On my Win10 desktop, I've installed a virtual machine of CentOS, and hope to make its display resolution fully utilize my hardware capacity (1920 x 1080).

For Hyper-V,

  • in context of "Hyper-V Manager > host > Hyper-V Settings > Enhanced Session Mode", I've checked the box of "Use enhanced session mode";
  • in context of "Hyper-V Manager > vm > Settings > Integration Services", I've checked all the boxes, including "Guest services".

When I maximize the connection, the window maximizes to full screen but the guest operating system reminds at lower resolution as "1152 x 864 (4:3)", and that was the only option in the Linux context of "root user > Taskbar > Applications > System Tools > Settings > Devices > Displays".

I hope to make the guest Linux operating system adapt to full screen display resolution, and any pointers will be highly appreciated.

Please also let me know if you need additional information.

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
2,617 questions
{count} votes

3 answers

Sort by: Most helpful
  1. JiayaoZhu 3,911 Reputation points
    2021-04-07T03:10:32.157+00:00

    Hi,

    Thank you for your reply!

    After my research, the grubby command may only work for a few screen resolution. Based on your descriptions, your failure to use this command is related to the poor support from your driver for your graphics card. I suggest you can first try to open up a huge of resolutions for your graphics card. The article below is suitable for Centos 7:

    https://superuser.com/questions/750382/how-to-change-resolution-of-centos-6-5-resolution-on-virtualbox-host-win7

    (Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

    Secondly, you can try some other solutions to solve your issue. Here are some methods you can try:

    1)Reinstalled the system in a fresh VM, and re-applying the grubby command

    2)To install xrdp and use remote desktop. See article:

    https://www.itzgeek.com/how-tos/linux/centos-how-tos/install-xrdp-on-centos-7-rhel-7.html

    (Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

    More information you can find:
    https://superuser.com/questions/1118192/updating-the-screen-resolution-in-centos7-in-hyper-v

    (Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

    If you still cannot maximize your resolution, I guess you may have to change your drive which can better support your graphics card. And you can ask your retailer for this information.

    Thank you for your support!

    Best regards
    Joann

    --------------------------------------------------------------------------------------------------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    2 people found this answer helpful.
    0 comments No comments

  2. Alec Parfitt 6 Reputation points
    2023-03-15T20:02:23.2066667+00:00

    The correct answer to this is to use Remote Desktop instead of launching the VM directly through the Hyper-V launcher. If you have Hyper-V, then you have Windows Pro so just enable Remote Desktop and search "Remote Desktop" in the taskbar search. If the target machine is Linux OS, find an RDP server like xrdp, enable it, start it, find the ip of the target machine, and use that to connect from from Remote Desktop. If the target machine is Windows, you'll have to enable RDP through the settings and do the same thing.

    1 person found this answer helpful.
    0 comments No comments

  3. JiayaoZhu 3,911 Reputation points
    2021-04-02T06:30:46.307+00:00

    Hi,

    Thank you for your posting!

    Based on your descriptions, first I would like to explain your issue:

    "1152 x 864 (4:3)" is the default screen resolution and the way that you have tried: "root user > Taskbar > Applications > System Tools > Settings > Devices > Displays" is for Ubuntu Hyper-V guests and is not suitable for CentOS and Red Hat VMs.

    In this case, you can use the grubby tool to change your screen resolution in CentOS to the biggest size that you want. You can follow the steps in the video to setup:

    https://www.netometer.com/blog/?p=1663

    (Please note: Information posted in the given link is hosted by a third party. Microsoft does not guarantee the accuracy and effectiveness of information.)

    Thank you for your time!

    Best regards
    Joann

    --------------------------------------------------------------------------------------------------------------------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.