question

croxx-6784 avatar image
0 Votes"
croxx-6784 asked croxx-6784 edited

Why Visual Studio 2015 IDE switches Editor font from my own choice to its default (Console)

I'm experiencing a strange behavior when Visual Studio (2015) occasionally switches from my own choice of Editor font (Courier New) to its default (Console). Did not find and did not notice a specific scenario when it happens. It just happens, after some time (could be less than an hour after I return my own choice, could be longer). Could anyone suggest a solution for this?

Thank you in advance.

vs-general
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.


Go to menu, Tools, Options, Environment, Synchronized Settings and try disabling the synchronisation, which maybe has some transient issues.

Consider modern Visual Studio too.

0 Votes 0 ·

Thanks a lot for your reply. I have disabled synchronization but the occasional "back-to-default-Console-font" glitches still happen.

I'm starting to think that maybe changes to "Display and layout" from 100% to 125% and back, for main screen (have 2, sometime 3, monitors) are somehow connected?.. Anyway, it does not happen strictly after some specific event.

0 Votes 0 ·

1 Answer

AnnaXiu-MSFT avatar image
0 Votes"
AnnaXiu-MSFT answered croxx-6784 commented

Hi @croxx-6784,

Welcome to Microsoft Q&A!

Please have a try with the workarounds above from Viorel-1.

In addition, you can also try to install the Visual Studio 2015 Update 3 and launch your VS in safe mode.

Sincerely,
Anna


If the answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.



· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

The visual studio was installed with Update 3... You suggest to always run VS in safe mode?

0 Votes 0 ·