question

Brad0117-3488 avatar image
1 Vote"
Brad0117-3488 asked Brad0117-3488 commented

how do I resolve native linking failed after updating VS for Mac 2019. Xamarin.Forms iOS

I updated to VS for Mac version 8.9.4. Xamarin.iOS version 14.14.2.5 and now I get native linking failed errors. I have linker behavior set to Link SDK's only and I get 31 errors. If I set linker to Don't Link, I get 55 of the native linking errors. If I set to Link All I don't get any build errors, but then my dependency service doesn't work. I can get around that with a Preserve attribute but then I get errors other places in the app. Anyone else have this issue with the latest update?

dotnet-xamarin
· 4
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi @Brad0117-3488 ,did this problem not occur before you upgraded? Have you made any changes for your app?

0 Votes 0 ·

@JessieZhang-2116 this problem did not occur before I updated. I can download a previous version of Xamarin.iOS 13.xxx and the app will build and deploy to a device once. But if I rebuild the app, I get linker errors again. The only thing I've changed since the update is adding the package Microsoft.Extensions.Primitives (2.2.0) to the iOS project. I would get an InplaceStringBuilder error otherwise. I'm not sure what package I'm using that's still referencing that but I don't believe that has anything to do with the linker errors.

0 Votes 0 ·

Could you please post a basic demo to github or onedriver so that we can test on our side?

0 Votes 0 ·
Show more comments

0 Answers