question

Marcus-9726 avatar image
0 Votes"
Marcus-9726 asked Marcus-9726 commented

SQL Failover Cluster Instance DNS failure for Resource VNN

I have a SQL 2016 failover cluster instance in Windows Server 2016 environment. This was migrated from a previous 2012 cluster using side-by-side migration. Please refer below more the environment setup:

OLD environment: SQL 2012 cluster, WSFC VNN=WSFCHOSTNAME.domain.local, SQL VNN=SQLHOSTNAME.domain.local

Once setup the new SQL 2016 cluster and migrated everything over, I decommissioned the old cluster and cleaned up everything left out from AD such as computer object/DNS record. Then I renamed the WSFC and SQL VNN of new cluster to the name as old environment as well as swapping the IP address. However, the WSFC VNN showing DNS OK, it can register the DNS record by itself without any issue. For SQL VNN, it is unable to register DNS and the status is showing "DNS failure". If I rename the SQL VNN to other name like SQLHOSTNAME2, it doesn't have any issue. But when I rename it back to original name of SQLHOSTNAME then the same issue occur. I will have to manually create the DNS record as a workaround. But the error message is still appearing as the cluster is attempting to register DNS every 15/30 minutes I guess but it failed.

I have tried all the suggestions from internet article like deleting the DNS record and recreate 1 with the option "Allow any authenticated user to...". Manually assign the cluster node computer object and WSFC computer object FULL ACCESS permission of the DNS record. Point the cluster nodes to different DNS IP. I even logged case to Microsoft but still not able to resolve the issue until now (It has been few months since I logged case to Microsoft).

We have a requirement to maintain SQLHOSTNAME so the workaround of renaming the SQL cluster to a new name is not applicable to us as a final solution. Therefore, I'm trying to post question here to see if there are any other fixes/solutions that I could try to resolve this issue.

The following are the error logs that I retrieved from the cluster and nodes:

85456-image.png


85513-error-2.png


85514-error3.png


sql-server-generalwindows-serverwindows-server-2016
image.png (166.2 KiB)
error-2.png (174.0 KiB)
error3.png (148.4 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

XiaoweiHe-MSFT avatar image
0 Votes"
XiaoweiHe-MSFT answered Marcus-9726 commented

Hi,

Based on my understanding, the issue you met is that we are unable to register the SQL instance name with the original one.

Please check if you have tested the following things:

  1. Please check on the DNS server, check if there's any related error log on the DNS server side.


  2. Please try to clear DNS cache on the cluster nodes, then clear DNS cache on the DNS server and reload the zone on the DNS server, and check if the record can be registered.

Thanks for your time!
Best Regards,
Anne


If the Answer is helpful, please click "Accept Answer" and upvote it.
Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Hi Xiaowei,

I've tried suggestion no.2 previously, unfortunately it doesn't resolve the issue. For suggestion no.1, I will try to see if I can find anything new from there that is related to this issue again as I have searched for that previously but could not see anything related from there.

Thank you.

0 Votes 0 ·