question

reuvygroovy avatar image
0 Votes"
reuvygroovy asked reuvygroovy action

SMB Multi-Channel Not working

I have two Windows 2019 Servers. Each server has a 2 x 10Gb Team of adapters grouped together as a single interface. I am transferring a bunch of large ISO files (each between 5-20GB) at the same time from one to the other.

I have checked on the both servers and both command on each return True:
Get-SmbClientConfiguration | Select EnableMultichannel
Get-SmbServerConfiguration | Select EnableMultichannel

But when I copy the above mentioned files from one host to another, when running the command Get-SmbMultichannelConnection I don't see any connections (IPs) from any of these servers (on both servers). I also don't think I am using both adapters since my throughput (which theoretically should be 20Gb usually caps at about 500-600MB/s.

86968-image.png


windows-server
image.png (6.3 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

reuvygroovy avatar image
0 Votes"
reuvygroovy answered CandyLuo-MSFT commented

I have two 10Gb adapters in a Team, so for the 20Gb Team:

87662-image.png


87663-image.png



image.png (12.2 KiB)
image.png (21.2 KiB)
· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

You might temporarily disable firewall on both side on then check whether SMB Multi-Channel works.

0 Votes 0 ·
CandyLuo-MSFT avatar image
0 Votes"
CandyLuo-MSFT answered

Hi,

Please first make sure the binding for the NIC is set to true for SMB client (MS_client) and SMB server (MS_server).

The command below should show True under Enabled for both: Get-NetAdapterBinding -ComponentID ms_server,ms_msclient

After that, make sure the network interface is listed in the output of the following commands: Get-SmbServerNetworkInterface Get-SmbClientNetworkInterface

If everything looks good there, check the firewall. Make sure SMB traffic is not blocked by firewall. If the network profile is set to Public. This means that SMB is blocked at the firewall by default.

The following article talks about how to troubleshoot SMB Multichannel issue, you could have a look: SMB Multichannel troubleshooting

Best Regards,

Candy


If the Answer is helpful, please click "Accept Answer" and upvote it.

Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

reuvygroovy avatar image
0 Votes"
reuvygroovy answered CandyLuo-MSFT commented

No firewall. This is on a LAN.

· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Have you checked windows firewall?

0 Votes 0 ·

Yes, Allow Any-Any

0 Votes 0 ·

Temporally disable windows firewall on both sides to do a test. If it still doesn't work, you need to trace network traffic to find the cause.

0 Votes 0 ·
reuvygroovy avatar image
0 Votes"
reuvygroovy answered CandyLuo-MSFT commented

What would I be looking for in a traffic trace?

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Look for the NETWORK_INTERFACE_INFO packets. You can refer to the following article: Capture client and server sided traffic for troubleshooting




0 Votes 0 ·
reuvygroovy avatar image
0 Votes"
reuvygroovy answered CandyLuo-MSFT commented

Working on it. Hope to update soon.

· 1
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

I will wait for your new updates.

0 Votes 0 ·