Azure ML Notebook Python kernel never loads

Emilio Gagliardi 16 Reputation points
2021-04-13T01:58:57.097+00:00

Hello,

I'm working through mslearn examples. I created a Workspace and a Compute instance based on provided specs [Standard_DS11_v2 (2 cores, 14 GB RAM, 28 GB disk)]

The compute instance deploys and runs fine. I tried to open a terminal to clone the dp100 examples, but the terminal always fails, even with the compute instance selected. I tried restarting the compute instance and the terminal never loaded.

Parallel to that, when I create an ML Studio notebook, the compute instance says its running, but the Python 3.6 kernel never loads so I can't run cells from the Notebook. However, if I open the contents of the Notebook in the Jupyter editor it runs fine.

I was able to run the git clone code using the above, but I'd like to understand why the notebooks and terminal aren't working as they should be.

I was following these instructions: https://microsoftlearning.github.io/mslearn-dp100/instructions/01-create-a-workspace.html

87116-notebooks-microsoft-azure-machine-learning.png

87205-dp100-compute-instance-microsoft-azure-machine-lea.png

Azure Machine Learning
Azure Machine Learning
An Azure machine learning service for building and deploying models.
1,634 questions
1 vote

1 answer

Sort by: Most helpful
  1. YutongTie-MSFT 24,466 Reputation points Microsoft Employee
    2021-04-15T03:16:36.117+00:00

    Thanks for the confirmation.

    Yes, this should work now. Please let us know if you see this again. I will convert my comment to answer, please feel free to accept. Thanks.

    Regards,
    Yutong