Group Policy Client service failed the logon. Access denied.

Jim K Lex 21 Reputation points

I have a Windows 7, Home Premium.

On June 9, 2020, there was a windows update performed on my computer. Shortly thereafter, my event logs show a critical error that restart was attempted without a proper shutdown. (Not sure why as it happened late at night on an automatic update).

From the next morning on, when i attempt to boot up, i get “The Group Policy Client service failed the logon. Access is denied.”
I am a single computer. My user profile is the only profile. While i am unable to logon in normal mode, i am able to log into safe mode.

I have tried many of the typical troubleshooting suggestions found on youtube or other forums/searches to no avail.

I have disabled all startup programs. No luck.
I have edited the registry (carefully) and changed back those edits if they didnt work. No luck.
I have tried System restore to previous restore points. No luck.
I noticed a lot of solutions to add a GPSvc folder,etc into the SVChost folder...but my Group policy in services.msc shows netsvcs instead of GPSvc. None of the solutions i’ve seen so far deal with netsvcs. But that might not even be the problem, its just something i noticed,

I have not done any user profile solutions suggested as ii’m not sure if it would be helpful to do and gets into possibly deleting my files?

I don’t see this issue listed in any forums,etc after 2017 so I’m curious why i would first have this problem now in 2020...but again, it does seem to have followed a critical error of a crash after a Windows update.

Any suggestions on what to try or where to go?

Not Monitored
Not Monitored
Tag not monitored by Microsoft.
27,084 questions
0 comments No comments
{count} votes

Accepted answer
  1. Dave Patrick 353.3K Reputation points MVP

    Windows 7 is not currently supported here on QnA. They're actively answering question in dedicated forums here.

    --please don't forget to Accept as answer if the reply is helpful--

    Regards, Dave Patrick ....
    Microsoft Certified Professional
    Microsoft MVP [Windows Server] Datacenter Management

    Disclaimer: This posting is provided "AS IS" with no warranties or guarantees, and confers no rights.

4 additional answers

Sort by: Most helpful
  1. Manu Philip 14,551 Reputation points MVP

    Hello @JimKlex-1451,

    The reason for these whole issues started from an improper shutdown and especially during the windows update. I would recommend you to run the command sfc /scannow from elevated command prompt. This will check the file system and repair if needed. Make sure that your installation media is also ready (if asked to be inserted)

    Please mark as "Accept the answer" if the above steps helps you. Others with similar issues can also follow the solution as per your suggestion



    0 comments No comments

  2. Jim K Lex 21 Reputation points

    Thanks ManuPhilip,

    I’m going to spend today doing 3 things:

    1. Backup my files while in safe mode, just in case.
    2. I have a couple other old laptops that i think run Win 7, so I’m going to compare the reg edit settings they have in the SVChost file. I tried the GPSvc fixes in regedit that are prevalent on youtube/online search, my computer did not have the GPSvcGroups folder/files but when i added them as instructed, there was no change in my problem. Thats where i noticed i had the “-k netsvcs” in Group Policy path in services.msc & not “-k gpsvc”.
    3. I’ll look to do the scan you suggested in your reply.
      Thanks again.
    0 comments No comments

  3. Jim K Lex 21 Reputation points

    Although the recommendation to run a scannow command did run and at the end it did say corrupted files were found and repaired, unfortunately, it did not solve my problem & i still had the error message of group policy client failed at logon, access denied.
    I have moved on to copying my Important files onto a zip drive while in safe mode. Then i have created a new user following the instructions at:
    This at least got me into normal mode as a user and am now attempting to copy/paste from the old corrupted user files as instructed from that link.

    0 comments No comments

  4. Dharanesha E 1 Reputation point

    I'm fed cleaning registry up , I did all sort of troubleshoot .
    We have 4 TS(terminal service enabled) and used by thousands of people.
    Apart from what you mentioned here, in this question, what else can be checked?

    0 comments No comments