Microsoft Virtual Adapter disable automatically after reboot. Hyper-V, Windows server 2019

Retheesh Reghuvaran 101 Reputation points
2021-04-14T05:47:17.037+00:00

Hello Team,

I have two Dell PowerEdge R740 Servers installed with Windows server 2019 Std (Version 1809 (OS build 17760.379). Have created Hyper-V role on it and configured a virtual switch as well. After restart the server, i found that the Microsoft Virtual Adapter disabled.

I tried to enable it in network connections page, it was not enabling.

Then I open the device manager and disabled then enabled the Hyper-V virtual ethernet adaper, then starts working.

whenever I restart the server, its disabling automatically.

Regards

Retheesh.

Hyper-V
Hyper-V
A Windows technology providing a hypervisor-based virtualization solution enabling customers to consolidate workloads onto a single server.
1,831 questions
Windows Server 2019
Windows Server 2019
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
2,207 questions
{count} votes

Accepted answer
  1. Retheesh Reghuvaran 101 Reputation points
    2021-05-12T06:53:25.557+00:00

    At last i found out the problem. Our security software Sentinel One was disabling the Hyper-V Virtual Switch.
    Uninstalled Sentinel One and the server is functioning properly now.

    Thanks for all your comments and help.

    No comments

3 additional answers

Sort by: Most helpful
  1. Reza Ameri 14,616 Reputation points
    2021-04-14T14:29:11.8+00:00

    Try update Windows and the network driver.
    Check event viewer and see if there is any error or warning related to this issue?

    No comments

  2. Dave Patrick 330.5K Reputation points Microsoft MVP
    2021-04-14T16:10:48.69+00:00

    I'd check that windows has been patched fully. Also check the latest firmware, ROM bios, chipset, and driver supports packs have been installed.

    Also try deleting / recreating the vSwitch. When you create a new external vSwitch the internet protocols are removed from the adapter and the Hyper-V Extensible Switch protocol is added turning that physical port into a multi-port virtual switch. Connect your VMs to this switch

    --please don't forget to Accept as answer if the reply is helpful--


  3. Dave Patrick 330.5K Reputation points Microsoft MVP
    2021-04-23T12:54:37.363+00:00

    Should have worked out of the box. Make sure that you do not edit the vSwitch or vEthernet properties after creation.
    https://learn.microsoft.com/en-us/windows-server/virtualization/hyper-v/get-started/create-a-virtual-switch-for-hyper-v-virtual-machines

    --please don't forget to Accept as answer if the reply is helpful--