SessionTimeout set by Set-SmbClientConfiguration does not work and alawys less than 20 seconds

asked 2021-04-16T02:39:25.393+00:00
hzz hzz 6 Reputation points

This question is about samba,the environment is as follows :
Samba Server

System info : CentOS Linux release 7.6.1810
Network : Virtual IP create by ifconfig eth0:231 192.168.0.231 netmask 255.255.255.0 up

Samba Client

System info : Windows Server 2012R2

**Here are the steps to reproduce the problem : **

  1. Create a samba share in CentOS
  2. Creates a SMB mapping on the Windows Server 2012R2 SMB client to the SMB share created in step 1
  3. In Windows Server 2012R2 SMB client path, Use fio to simulate a given I/O workload : fio -filename=cifs.txt -iodepth=1 -direct=1 -ioengine=windowsaio -thread -rw=write -bs=1k -size=1g -numjobs=1 -group_reporting -name=mytest
  4. In CentOS samba server, run the command date; ifconfig eth0:230 down
  5. We found that the fio failed after 20 seconds and windows smb client disconnect with smb server

I want to increase the disconnect time,Microsoft Doc tells me that the parameter SessionTimeout set by Set-SmbClientConfiguration means the number of seconds that the client waits before disconnecting an inactive session. But When I set this parameter to more than 20 by Set-SmbClientConfiguration -SessionTimeout 60, the timeout is always 20 seconds, this parameter only works when be set to less than 20 ,e.g. Set-SmbClientConfiguration -SessionTimeout 10

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,121 questions
Windows 10 Network
Windows 10 Network
Windows 10: A Microsoft operating system that runs on personal computers and tablets.Network: A group of devices that communicate either wirelessly or via a physical connection.
1,934 questions
1 vote