Autodiscover failed after upgrade Exchange 2013 to CU23

NTD8685 1 Reputation point
2021-04-19T15:56:53.547+00:00

Hello,
After upgrade Exchange Server to 2013, the autodiscover cannot access with error:
89147-1.png

89148-2.png

But the OWA/ECP are working fine.

Plz help me to fix this issue.

Exchange Server Management
Exchange Server Management
Exchange Server: A family of Microsoft client/server messaging and collaboration software.Management: The act or process of organizing, handling, directing or controlling something.
6,092 questions
{count} votes

4 answers

Sort by: Most helpful
  1. NTD8685 1 Reputation point
    2021-04-19T16:11:49.44+00:00

    Hi AndyDavid,
    MSExchangeAutodisoverAppPool is started, I did to recycle it or restart server but no luck.
    89204-image.png
    I still get error.


  2. Andy David - MVP 109.8K Reputation points Microsoft MVP
    2021-04-19T18:13:05.57+00:00

    ok, looks normal.
    So EAC/OWA work, just not autodiscovery?
    Nothing in the event logs?
    No errors?

    See if resetting it fixes it in EAC:
    89232-image.png

    If all else fails, consider recreating the AutoD Virtual D:

    https://theitbros.com/recreate-owa-ecp-virtual-directories-exchange-server-2016/


  3. Yuki Sun-MSFT 24,761 Reputation points
    2021-04-20T03:14:01.823+00:00

    Hi @NTD8685 ,

    Please also have a check to see if a proper certificate is bound to the Exchange Backend website on port 444:

    1. Start IIS Manager on the Mailbox Server.
    2. Expand Site, highlight Exchange Back End, and select Bindings from the Actions pane in the right side column.
    3. Select Type https on Port 444, click Edit and check if the certificate is bound properly:
      89345-1.jpg

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  4. Andy David - MVP 109.8K Reputation points Microsoft MVP
    2021-04-20T11:43:27.403+00:00

    That's Incorrect. Not sure why thats allowing OWA and EAC are working and autodiscover is not with that cert, but that backend cert should be the self-signed Exchange Cert.
    See my blog on how to change it to the correct one:

    https://ehloergosum.com/2020/01/25/renewing-that-pesky-microsoft-exchange-certificate/

    From the article I first linked above. Do the following:

    Start IIS Manager on the Mailbox Server.
    Expand Site, highlight Exchange Back End, and select Bindings from the Actions pane in the right side column.
    Select Type https on Port 444.
    Click Edit and select the Microsoft Exchange certificate.
    From an administrator command prompt, run IISReset. ( Do this off-hours if this a standalone Exchange Server. If you are using a DAG, then move all the databases to other servers and have at it)