SharePoint 2019 site navigation breadcrumb does not work on system pages

Faiz Ahmed Mirza 1 Reputation point
2021-04-20T11:00:46.643+00:00

Hi All, I have enabled the navigation breadcrumb in the master page of my site in Sharepoint 2019.

When I navigate to a library inside a sub site and verify the URL on AllItems.aspx page it shows the correct url but when I navigate to the library settings page and verify the url in the same breadcrumb it only shows the url of the parent site and does not include in the URL of the subsite and the library (incorrect URL).

This behaviour is seen on all application pages only such as list / library settings page , site settings page , site contents page etc.

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
1,461 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Elsie Lu_MSFT 9,621 Reputation points
    2021-04-21T08:48:57.48+00:00

    Hi @Faiz Ahmed Mirza ,

    How did you modify your master page?

    You could try to:

    ensure that you have publishing feature enabled and is updating the seatle.html(or whichever is your master page) from SharePoint Designer and update the below html

    • remove "style:display:none" from the class "ms-breadcrumb-dropdownBox"
    • change Visible ="true" for SharePoint:PopoutMenu

    Once you have made these changes , Publish a major version.

    Pleaser refer to this post for more information:
    how to Enable Breadcrumb in SharePoint 2016

    Based on our test it works well:
    89836-5.jpg


    If the answer is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.