question

ArnoldSi-2406 avatar image
0 Votes"
ArnoldSi-2406 asked ajkuma-MSFT edited

Azure linux app service + .netcore 3.1 application error

Hello,
I developed .netcore 3.1 application and tried to deploy it using visual studio 2019.
I've created app service in azure:
10182-11.png


But when I publish the app I'm getting application error page (azure error page).

I went to bash and saw that .netcore that installed on the machine is 2.2 and not 3.1 although I selected 3.1:
10112-12.png


This is what I see in diagnostics:
10191-13.png


I even tried self contained app and still not working.



azure-webapps
11.png (51.0 KiB)
12.png (23.9 KiB)
13.png (32.2 KiB)
· 2
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Apologies for the delay in responding here. I was checking on this internally and noticed you had also filed a support ticket ending with '10323'.

To benefit the community, posting the solution that worked for you - the Issue was due to app couldn't connect to SQL server.

Apologies for any inconvenience with this issue, thanks for sharing the update.

If you have any further questions, kindly let us know we would be more than happy to assist you.

Thanks again for your patience and co-operation!

0 Votes 0 ·

I have reached out to you offline further discussion. Just adding useful Azure deployment troubleshooting resource:

App startup errors and Troubleshoot on Azure App Service - Provides common causes and steps to resolve issues.

Configure a Linux ASP.NET Core app for Azure App Service - Configuration and diagnostic logs.

Azure App Service on Linux FAQ


Apologies for any inconvenience with this issue, thanks for sharing the update.
If you have any further questions, please do let us know.


0 Votes 0 ·

0 Answers