How to have SharePoint 2013 'Attachments' and 'paper clip' on the list?

Annie 81 Reputation points
2021-04-21T19:56:21.52+00:00

Good afternoon,

How to make 'Attachments' as a column and show the paper clip on the list after the users attached their documents?

The issue is when I tried to add 'Attachments' to the new column, an error popped up and said this values is default and is reserved by the SharePoint so I can't use 'Attachments'. But we need to attach our document to one of our task lists and show paper clip on the list so the reviewers will know which items have attachment. Your assistance will be great appreciated.

Thanks,
Annie Tang

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,366 questions
SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
6,082 questions
No comments
{count} votes

Accepted answer
  1. Jerry Xu-MSFT 7,781 Reputation points
    2021-04-22T02:03:18.603+00:00

    Hi, @Annie ,

    If you want to display the 'paper clip', you need to modify the view to show the attachments column. It is a reserved column handled by SharePoint.

    In the ribbon, you can find a button named modify current view and display the attachments column.
    90108-image.png

    Then you will be able to see if the task has attachment.
    90110-image.png


    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.

    No comments

1 additional answer

Sort by: Most helpful
  1. Annie 81 Reputation points
    2021-04-22T15:07:02.23+00:00

    Hi Jerry,

    It works! Thank you so much. Now paper clips shows on the list if the users attached their files to the task item. Those haven't attached the attachments column is empty. This is what we expected.

    Thank you again,
    Annie Tang

    No comments