SharePoint 2019 via Azure AD Application Proxy blank login page during SSO (KCD) from Office clients

Martin Ericssson 21 Reputation points
2021-04-23T07:57:23.457+00:00

We have multiple implementations of SharePoint together with Azure App Proxy. The whole concept has worked very well for a long time.
Now a problem has arised during content editing from Office clients. Regular web access to SharePoint and OOS editing works fine.
The SSO is working with login.microsoftonline.com but then a blank page with the SP external URL is shown and hangs:
90610-image.png

From Azure perspective the logon is interrupted:
90665-image.png

From a Fiddler perspective we see the following last error:
?state=AppProxyState%3a%7b%22InvalidTokenRetry

Closing the blank page will open the content but will present the following:
90658-image.png
After pressing sign in you can edit and save the content without any problem.

I have now seen this problem on all of our implementations for different customers/tenants.
Have anyone else faced this and are aware of any workaround?

Thanks!
Martin

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,669 questions
No comments
{count} votes

Accepted answer
  1. Siva-kumar-selvaraj 15,116 Reputation points
    2021-04-23T17:17:49.103+00:00

    Hello @Martin Ericssson ,

    Thanks for reaching out and sorry for the inconvenience caused.

    I would like to inform you about an issue that is being investigated by the Azure AD Application Proxy Product Group. We know what causes the issue, but it’s

    not confirmed yet what component causes it. No ETA on the fix at the moment.

    Scenario: Office Client (Word, Excel..etc.) tries to load an Office document hosted on a web server that is published over Azure AD Application Proxy.

    The authentication is successful, the authentication windows turns into blank and won’t be closed.

    90837-image.png

    The window can be closed manually and the document gets loaded. Office on mobile devices behaves differently (!). The document cannot be opened.

    I will keep you updated on this thread once issue has been resolved. I appreciate your patience while our product team fixing the issue.

    Hope this helps.

    ------------

    Please "Accept the answer" if the information helped you. This will help us and others in the community as well.


0 additional answers

Sort by: Most helpful