AAD Login uses logged in user by default

Sanjeev Nachimuthu 1 Reputation point
2019-12-18T18:16:45.867+00:00

Hi,

I have a few applications that use AAD for authentication.

Current behavior: I am logged into my desktop using a@keyman .com. I launch the application, the app redirects to the AAD login screen and enter b@keyman .com as the user name. When I click the login button the application logs in automatically using a@keyman .com and completely ignores b@keyman .com

Purpose: I am trying to use synthetic transactions (Dynatrace) to monitor the application. When the scripts use a username to login it is completely ignored and AAD uses the Local System user to login and AAD does not consider it as a valid user. It completely ignores the user b@keyman .com that is entered in the username field.

Expected behavior: I should be able to logon to the application using any username/password irrespective of the user logged on to the computer or the user context the service is running under.

thanks

Azure Active Directory
Azure Active Directory
An Azure enterprise identity service that provides single sign-on and multi-factor authentication.
12,604 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Lukas Beran 171 Reputation points
    2019-12-18T19:58:34.737+00:00

    Does it work in inprivate mode? What about different browsers like Firefox, Opera, or Chrome without the Microsoft Account extension? Then seamless SSO should not work so you should be able to use any account.

    No comments

  2. Sanjeev Nachimuthu 1 Reputation point
    2019-12-18T21:08:14.503+00:00

    I have tried both Chrome and Firefox. The same behavior is there too. Same behavior in private mode too. The only way for me to login as another user is to use the "Run as another user" option to launch the browser. While this will work on my desktop I cannot run the Dynatrace service under a user account, it works only as Local System user.

    Also the user b@keyman .com can be just anything, does not look like AAD is even using what I entered there. I used psexec to launch the browser in Local System user to replicate the issue.

    No comments