Having issues with Replace Function in QA Testing bug

asked 2021-04-28T02:27:59.753+00:00
Mike Kiser 1,526 Reputation points

Hi! @Nasreen Akter @MartinJaffer-MSFT

Well, another QA bug that I "get" to solve :-)

All of our telephone numbers from our json data file are in the following format 787/215-1312 . I haven't worked with phone numbers and ADF expressions and have been trying to solve this. I do a lookup and get the following phonenumber "@{item().phonenumber}" which I use in a web activity to update employees phone numbers in Ceridian. I am trying a REPLACE function but having no luck. I have tried

replace( @item().phonenumber,'/','-') to get a phonenumber like 787-215-1312 but no luck. Any suggestions?

Thanks!
Mike

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
6,254 questions
{count} votes

1 answer

Sort by: Most helpful
  1. answered 2021-04-28T13:16:57.683+00:00
    Nasreen Akter 10,601 Reputation points

    Hi @Mike Kiser ,

    The expression you have is correct i.e., replace(@item().phonenumber,'/','-') and is working fine for me. Would you please check if the attribute name is phonenumber or phoneNumber? Thanks!

    No comments