Windows 10: unwanted keyboard layouts appear after upgrade to version 20H2

Evgeny Lotosh 156 Reputation points
2021-04-29T19:19:43.447+00:00

I have two non-English keyboard layouts in my Windows 10 Home settings. Recently Windows Update forced me to update the OS to version 20H2. Immediately after that unwanted English keyboard layouts started appearing on the layout list: English UK (UK and international layouts) and English US. The layouts are present only on the tray keyboard indicator, not on the list of installed languages in Windows 10 settings. The only way to remove them is to install these languages / layouts in Windows settings and then uninstall them. However, they return back shortly after that, sometimes several times a day.

I already had that problem in the past in one of previous Windows builds. I searched forums and did everything described in found forum posts. It didn't help. However, it disappeared later (maybe as a result of my efforts but most probably as a result of some Windows patch). Now the problem is back.

Is there any way to prevent Windows from automatically installing keyboard layouts?

P.S. There is some software on my machine (including MS Office 2016) with English user interface and English spelling dictionaries. I do need them and don't want to uninstall them.

Windows 10
Windows 10
A Microsoft operating system that runs on personal computers and tablets.
10,994 questions
0 comments No comments
{count} votes

Accepted answer
  1. Evgeny Lotosh 156 Reputation points
    2021-05-07T20:55:24.567+00:00

    So here are the results of my experiments:

    1) The issue can be resolved if individual language selection for different applications is disabled ("Let me use a different input method for each app window" unchecked in "Advanced keyboard settings"). However, it makes working with several applications in parallel significantly uncomfortable.

    2) The second methods is to hack the registry.

    Simply removing registry key "HKLM\SYSTEM\CurrentControlSet\Control\Keyboard Layout" doesn't work. Windows restores it after reboot and the issue is back. However, there is another way (attention! for skilled users only!). You need to remove all values in that key and then edit security settings by removing all access rights (especially the rights for SYSTEM) except maybe the right for your user account. I don't provide a detailed description of the method to make a natural barrier for people who have no experience and have a high risk of irrevocably corrupting the registry.

    2 people found this answer helpful.

2 additional answers

Sort by: Most helpful
  1. Karlie Weng 15,761 Reputation points Microsoft Vendor
    2021-04-30T06:09:59.99+00:00

    Hello @Evgeny Lotosh

    Have you tried the PowerShell and Edit Registry method provide in this article : FIX: Windows keeps automatically adding EN-US keyboard layout

    And this thread: How to prevent Windows 10 from automatically adding keyboard layouts (i.e. US keyboard) could help.

    Best Regards
    Karlie

    ----------

    If the Answer is helpful, please click "Accept Answer" and upvote it.

    2 people found this answer helpful.
    0 comments No comments

  2. Evgeny Lotosh 156 Reputation points
    2021-04-30T08:16:00.973+00:00

    Hi @Karlie Weng

    Thanks for the links. I recall I did everything described in these articles when the issue manifested last time with no success. Powershell, registry modifications and so on - there was no effect. Layouts continued to reappear all the time, modified registry entries were back, even removing all Modify permissions on registry keys (including ones for SYSTEM) didn't help.

    Well, maybe something helped in the end but the last Windows build upgrade removed/reset something. Although, most probably, MS simply reintroduced this bug/"feature" as it did with the visual keyboard switching indicator that also started appearing again at most inappropriate moments.

    I'll try to perform all these actions again. I've also installed the latest quality rollup for Win10. Maybe it's fixed there. Thanks again for the tip.