SSAS converts zero and low decimals into nulls when processing cube

Llecktv 1 Reputation point
2021-04-29T19:31:52.09+00:00

Hi guys, as the title states when I process the cube I get several values converted into nulls in 2 measures from my cube (measures datatype=currency, source column in SQL DB=money).
Values like '0.13', '0.04' or '0.00' are stored in my source database and I get to see them there with no problems. I can see them too in the DSV and in the cube itself when I Explore Data.
But the moment I process the cube about 3000 records get transformed in nulls so I can't perform aggregations or filters in a proper way. I tried to fix it by setting it to ZeroOrBlank in 'Nullprocessing', I tried some combinations in 'FormatString' and I even changed the datatype to decimal and numeric (in both source and cube) but nothing seems to work.
Has anyone face this before? Is there something that I am missing? Any help would be appreciated. Thanks.

SQL Server Analysis Services
SQL Server Analysis Services
A Microsoft online analytical data engine used in decision support and business analytics, providing the analytical data for business reports and client applications such as Power BI, Excel, Reporting Services reports, and other data visualization tools.
1,000 questions
No comments
{count} votes

1 answer

Sort by: Most helpful
  1. Lukas Yu -MSFT 5,796 Reputation points
    2021-04-30T07:14:12.833+00:00

    Hi,

    Have you set the column format ? Check the property and set you column format so you could have 2 decimal place measure.

    You could follow the suggestions in this thread: Any way to control number of decimal places while browsing SSAS cube?

    Regards,
    Lukas