Data Factory Azure hosted integration runtime managed Vnet stays in Running (Limited) status after creation

Dhananjaya Mata 11 Reputation points
2021-04-30T02:59:14.11+00:00

Hi there,
I have created data factory with Azure hosted integration runtime with managed virtual network. But after creation, the status of the integration runtime stays in 'Running (Limited', with the below message:

Data movement, interactive query, pipeline and external activities: Succeeded
Dataflow: Failed
IRs can take 15 minutes to be ready for dataflow from the time they are created.

Location: Australia East.

Could you please help on what could be wrong here? I have tried the repair option and that has not fixed the issue.

Azure Data Factory
Azure Data Factory
An Azure service for ingesting, preparing, and transforming data at scale.
9,149 questions
{count} votes

3 answers

Sort by: Most helpful
  1. Andreas Hug 21 Reputation points
    2021-07-05T08:22:26.333+00:00

    I'm currently experiencing the same issue. Repairing does not resolve the issue either...
    Do you have any information on how to resolve this problem?

    2 people found this answer helpful.

  2. KranthiPakala-MSFT 46,407 Reputation points Microsoft Employee
    2021-05-06T06:29:49.973+00:00

    Hi @Dhananjaya Mata ,

    Sorry for the delay in response. We just received an update from ADF product team that they have identified some quota limit issue in the backend and have applied mitigation steps to resolve this issue.

    Could you please try repairing the IR in limited status and see if the issue is resolved on your end.

    Please do let us know how it goes.

    Apologizes for the inconvenience because of this issue.


  3. DNH-5689 1 Reputation point
    2021-11-02T10:36:12.57+00:00

    I have also hit this issue and reported it to Microsoft.

    Their answer was:

    After checking with our PG team, based on the backend logs, it appeared that the 200 limit for NIP has been reached for ADF subscription. Therefore, we requested and completed an increase in quota for the subscription that is hosting vnet. You should now be able to repair this IR from UX and it should work if the issue occurs again.

    Not sure what any of that means, but I can confirm that this has resolved the issue.

    0 comments No comments