Sharepoint url Issue

Deepak Hadpad 81 Reputation points
2021-05-03T05:16:54.877+00:00

Hi All,

In production all of sudden for few user SharePoint 2013 site is getting redirected default as https instead of http.

whether it is due to some system update on there system or CU patch installation in SharePoint server ?

Below I have tested but no luck

I just tested the alternate access mapping solution but it’s not working. Its not working because the https is not even accessible, so when ever user access the application with https request will not reach the server to consider it for alternate mapping

Is there any solution like

We wont be able to reproduce the issue, but the need is when you access the application with HTTPS it should either get redirected back to HTTP or application should be accessible in HTTPS itself,

Please do let us what might b the issue.

Thanks,
Deepak

SharePoint Server
SharePoint Server
A family of Microsoft on-premises document management and storage systems.
2,156 questions
SharePoint
SharePoint
A group of Microsoft Products and technologies used for sharing and managing content, knowledge, and applications.
9,210 questions
SharePoint Server Development
SharePoint Server Development
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Development: The process of researching, productizing, and refining new or existing technologies.
1,557 questions
SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,765 questions
0 comments No comments
{count} votes

3 answers

Sort by: Most helpful
  1. Emily Du-MSFT 39,606 Reputation points Microsoft Vendor
    2021-05-03T09:58:24.343+00:00

    @Deepak Hadpad

    Based on your description, I understand that when some users visit SharePoint site, site URL suddenly changes from http to https. If it is wrong, please correct me.

    You should go to the central administration of production environment to check whether it is configured alternate access mappings.

    Have you installed system update or CU patch in the production environment?

    You could refer following articles to configure alternate access mappings correctly.

    SharePoint 2013: Convert SharePoint web application from HTTP to HTTPS

    SharePoint HTTP to HTTPS redirect

    How to Change a SharePoint Web Application from HTTP to HTTPS?


    If an Answer is helpful, please click "Accept Answer" and upvote it
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Deepak Hadpad 81 Reputation points
    2021-05-03T10:51:41.697+00:00

    On the same Url http we are facing below issue . could not load any document library .
    93352-image.png

    0 comments No comments

  3. sadomovalex 3,621 Reputation points
    2021-05-03T14:47:32.733+00:00

    it may be browser cache issue - if some user accidentally entered "https" in browser one time browser may use that for future requests. Try to ask these users to open site in different browser or in private mode. If it will help - ask to cleanup browser history.

    0 comments No comments