question

Sirisian-9953 avatar image
0 Votes"
Sirisian-9953 asked MarileeTurscak-MSFT commented

Azure Enterprise applications "New Application" disabled. Also clicking create Non-gallery Appliciation says "Failed to add application "

Perhaps I have something misconfigured. I started the Azure trial just to be sure, but it didn't change anything.

When I go to Azure Active Directory I have a tenant already created so I click Enterprise Applications in the left area I see:

10330-azurerrror1.png

I also tried just going to the Overview page that shows the tenant and I scrolled down where it says Create and clicked Enterprise Application:

10392-azurerrror2.png

On that page it lets me select Non-gallery application:

10376-azurerrror3.png

When I enter any name though it just pops up a notification:

10364-azurerrror4.png

I'm just trying to do some simple SAML tests with an application, but I can't get past this part. Also the error message doesn't seem to have any other details. I assume this is an account configuration problem, but I'm out of ideas on how to solve it.

azure-active-directory
azurerrror1.png (8.0 KiB)
azurerrror2.png (26.1 KiB)
azurerrror3.png (83.5 KiB)
azurerrror4.png (96.3 KiB)
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

1 Answer

MarileeTurscak-MSFT avatar image
0 Votes"
MarileeTurscak-MSFT answered MarileeTurscak-MSFT commented

Hi @Sirisian-9953 ,



Can you please make sure that you have permission to create the application? Make sure that you are logging in with a role that has "Create" permissions such as an Application Administrator or Global Administrator role when you try this. https://docs.microsoft.com/en-us/azure/active-directory/users-groups-roles/directory-assign-admin-roles


· 3
5 |1600 characters needed characters left characters exceeded

Up to 10 attachments (including images) can be used with a maximum of 3.0 MiB each and 30.0 MiB total.

Next to the tenant it says "Your role Global administrator". That said I just realized I added the Azure trial to the wrong account which might be the issue.

0 Votes 0 ·

Did you try using the account with the trial added? Even if you're on a free tenant you should still be able to add applications.

0 Votes 0 ·

Does it give you any error detail?

0 Votes 0 ·