Multi Home SCOM 2019 Agent

Jason Steeves 136 Reputation points
2021-05-03T18:35:41.367+00:00

I'm trying to get a SCOM Agent to report into 2 different Management Servers by Multi-Homing it and not able to get this to work. From MG1 I'm discovering and pushing the client that installs and reports successfully..........then I use a powershell script to add the configuration for MG2 which gets inputted into the client successfully. The problem is the client never reports into MG2. When I install the client it's set to use the LocalSystem account to run actions.

Am I missing something hear? This seems to be a very straight forward process that is not working for me as it should. This is a lab environment and no firewalls are in place.

Operations Manager
Operations Manager
A family of System Center products that provide infrastructure monitoring, help ensure the predictable performance and availability of vital applications, and offer comprehensive monitoring for datacenters and cloud, both private and public.
1,396 questions
0 comments No comments
{count} votes

Accepted answer
  1. CyrAz 5,176 Reputation points
    2021-05-03T19:59:37.2+00:00

    Did you allow manually installed agent to join MG2? https://learn.microsoft.com/en-us/system-center/scom/manage-process-manual-agent-install?view=sc-om-2019
    If yes, did you set it to automatic approval? If not, you still need to approve them in "Pending managemen".
    Also go have a look in the event viewers of both the agent and the management server of MG2, you'll probably find interesting infos.

    0 comments No comments

1 additional answer

Sort by: Most helpful
  1. System Center guy 681 Reputation points
    2021-05-04T07:34:48.883+00:00
    1. at first, please review agent event log for any hint of the errors.
    2. Also review MG2 Management group which either allow automatic approve manual installed agent or review new manual installed agent in pending management.

    roger

    0 comments No comments