Organization customization enabled but not really?

asked 2021-05-05T12:46:06.313+00:00
Azazel90 361 Reputation points

I'm trying to import pst files into a new O365 tenant. The tenant already has multiple user accounts with payed (Office 365 E3) licenses, it's not a trial. Users are sending/recieving emails properly. As far as I know, to be able to import the pst files, I need to give my admin account the "Mailbox Import Export" role first, like this:

  1. Open an admin powershell
  2. Use command Connect-ExchangeOnline to connect to the tenant
  3. Run Enable-OrganizationCustomization to enable customization
  4. Run New-ManagementRoleAssignment –Role "Mailbox Import Export" –User "MyAdminUserName" to give my admin user the required role

Now the problem is that even after running the command in step 2 I'm getting an error message at step 4, telling me

The command you tried to run isn't currently allowed in your organization. To run this command, you first need to run the command: Enable-OrganizationCustomization.

I thought, okay I'll try to run step 2 again. But when I tried, I got the following error message:

This operation is not required. Organization is already enabled for customization.

So now what? Customization is enabled but not enabled? Did anyone face this issue before? I've done this many times in many different O365 tenants and never seen this happening.

Microsoft Exchange Online Management
Microsoft Exchange Online Management
Microsoft Exchange Online: A Microsoft email and calendaring hosted service.Management: The act or process of organizing, handling, directing or controlling something.
2,878 questions
No comments
{count} votes

Accepted answer
  1. answered 2021-05-05T14:35:32.6+00:00
    Azazel90 361 Reputation points

    Never mind. I had to wait for like an hour. Then it worked.

    No comments

1 additional answer

Sort by: Most helpful
  1. answered 2021-10-18T11:01:24.167+00:00
    Filip Heens 1 Reputation point

    thanks, I'm having the same issue... I'll wait for an hour now ;-)

    No comments