Sharepoint 2013 Crawl error when crawling Tif Files

Ross Urquhart 96 Reputation points
2021-05-05T12:54:31.523+00:00

When crawling Tif file in SharePoint 2013 i get the error 'Processing this item failed because of a timeout when parsing its contents' when reviewing the logs it has the Error ID 2147810853. I cannot find any reference to this Error ID.
The files are smaller than the MaxDownloadSize property. I have increased the timeout value to 600 seconds in the search service application, and I am not running out of memory. Any suggestions please.

SharePoint Server Management
SharePoint Server Management
SharePoint Server: A family of Microsoft on-premises document management and storage systems.Management: The act or process of organizing, handling, directing or controlling something.
2,761 questions
0 comments No comments
{count} votes

Accepted answer
  1. Ross Urquhart 96 Reputation points
    2021-05-12T08:50:51.56+00:00

    Thank you but the settings were already correct. It was a combination of issues. I had moved all the crawl components to another server but had not set up a timer job to restart the Search Service every morning (something we have found improves the Crawl Performances). The real problem was the File Format for TIF. I removed the File Type within Search then Remove--SPEnterpriseSearchFileFormat for tif. Restarted the Search Service then added these back in. one Full Crawl laeter and everything was working fine.


1 additional answer

Sort by: Most helpful
  1. Echo Du_MSFT 17,086 Reputation points
    2021-05-06T01:49:24.947+00:00

    Hello @Ross Urquhart ,

    Welcome to Q&A Forum!

    Please following steps:

    1)When you get this error first make sure you have enough resources (Ram,CPU, and Storage) on all farm servers participating in the crawl.

    2)Make sure this settings are set to the default settings :

    Go to C:\Program Files\Microsoft Office Servers\15.0\Search\Runtime\1.0\noderunner.exe.config and make sure <nodeRunnerSettings memoryLimitMegabytes=”0″ />

    94117-1.png

    3)Run the following PowerShell to change this settings :

    Set-SPEnterpriseSearchService -PerformanceLevel Reduced  
    Restart-Service SPSearchHostController  
    

    Confirm that the Performance Level configuration has changed by running the following command

    Get-SPEnterpriseSearchService  
    

    4)Increase the timeout value under "Farm Search Management" from 60 to 600

    94145-time-out.png

    Thanks,
    Echo Du

    ====================

    If an Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.