Unable to join server to domain

VIGNESHWARAN M 1 Reputation point
2021-05-06T15:00:17.67+00:00

Hi,

Trying to add one of Windows 2012 R2 server to domain and getting below mentioned error.

"DNS was successfully queried for the service location (SRV) resource record used to locate a domain controller for domain. and it's showing the list of domain controllers."

DNS server (non AD integrated) configured correctly in the server. Able to reach domain controller. Is there anything needs to be checked to resolve this issue.

Thanks in advance.

Windows Server 2012
Windows Server 2012
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,121 questions
Windows Server
Windows Server
A family of Microsoft server operating systems that support enterprise-level management, data storage, applications, and communications.
8,160 questions
Active Directory
Active Directory
A set of directory-based technologies included in Windows Server.
3,607 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Vicky Wang 2,556 Reputation points
    2021-05-07T09:52:17.69+00:00

    Hi ,

    Thank you for posting in our forum

    Your Domain Controller(s) are not registering with a DNS server correctly.

    Check the Domain Controllers IP settings, and ensure it's pointing at INTERNAL DNS servers

    Check the IP settings of the machine you are trying to join. If it's static, ensure it's pointing at INTERNAL DNS servers that the Domain Controller is pointed at

    Ensure that your DNS server is enabled and configured correctly

    Furthermore - have you used netdiag or dcdiag?

    Hope this information can help you

    Best wishes
    Vicky

    No comments

  2. Vicky Wang 2,556 Reputation points
    2021-05-10T05:55:02.53+00:00

    Hi,
    How are things going? Could you please send me an update so that we can continue to work on this problem and resolve it? Thanks for your help.
    Hope this information can help you

    Best wishes
    Vicky

    No comments