Simultaneous sessions

asked 2021-05-06T21:24:20.843+00:00
Rohan choudhary 21 Reputation points

I have windows server 2016 where number of simultaneous user sessions is not exceeding 10 and i want 14 sessions.

Done few steps:

  1. Reinstall remote desktop session host role
  2. Reapplied local policy
  3. Disabled limits

Still doesnot connect more than 10 sessions please suggest what could be the issue.

Server is physical blade server

Windows Server 2016
Windows Server 2016
A Microsoft server operating system that supports enterprise-level management, data storage, applications, and communications.
1,749 questions
{count} votes

3 answers

Sort by: Most helpful
  1. answered 2021-05-07T03:34:40.14+00:00
    Leila Kong 3,666 Reputation points

    Hello @Rohan choudhary ,

    1.Did you reboot the server or update group policy after disabling limits? Is there any error message if connecting more than 10 sessions?

    2.There should be no hard limit if the hardware is not an issue. Could you please provide the hardware information of the session host servers, like CPU, memory, disk capacity, C drive capacity, internal and external network bandwidth and graphics card? Have you used roaming profile or UPD?
    https://learn.microsoft.com/en-us/answers/questions/48774/what-is-the-maximum-rdsh-user-connections-can-i-ha.html

    3.Did you activate the licensing server and install per-user CALs on the licensing server?
    https://learn.microsoft.com/en-us/answers/questions/221714/how-to-allow-multiple-rdp-session.html

    Best regards,
    Leila


    If the Answer is helpful, please click "Accept Answer" and upvote it.
    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. answered 2021-05-10T09:53:50.483+00:00
    Leila Kong 3,666 Reputation points
    No comments

  3. answered 2021-05-27T07:34:38.837+00:00
    Leila Kong 3,666 Reputation points

    Hello @Rohan choudhary ,

    Just checking in to see if the information provided was helpful.
    Please let us know if you would like further assistance.

    No comments