"Use Shared Mono Runtime"

Calaghan Grainger 1 Reputation point
2021-05-07T17:43:36.167+00:00

Hi,

I have not been able to find an answer to this yet, but i have run into an issue when i try to archive an apk under my release branch. The archive fails and i receive a message stating that i must disable the use shared mono runtime. As far as i can see under the Android option under the sln properties there is no Use Shared Mono Runtime option. There is an option for Fast deployment, however that is already disabled. I have restarted Visual Studio after unticking fast deployment, I have rebooted my PC, Uninstalled and reinstalled Visual Studio, to no avail, checked in my manifest and confirmed it was "False" and pretty much everything else under the sun, yet the message still persists and will not let me archive. I am at a loss. I can archive fine in debug just not release

94891-screenshot-92.png
94876-screenshot-95.png

Xamarin
Xamarin
A Microsoft open-source app platform for building Android and iOS apps with .NET and C#.
4,824 questions
No comments
{count} votes

2 answers

Sort by: Most helpful
  1. JarvanZhang 23,851 Reputation points
    2021-05-10T01:55:19.307+00:00

    Hello,​

    Welcome to our Microsoft Q&A platform!

    Please ensure that you are using a release configuration and that "Use Shared Mono Runtime" option unchecked

    Please make sure you've selected the Release mode in the Configuration Manager option.

    95101-screenshot-2021-05-10-095222.png

    Best Regards,

    Jarvan Zhang


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Frank 1 Reputation point
    2021-08-08T22:05:09.14+00:00

    Doesnt work if you have custom build configs. Looks to me like a 2k19 bug. Option should not be greyed out.

    No comments