Guest users cannot access myapplication via email id on second time login

Naveen 1 Reputation point
2021-05-11T10:34:14.233+00:00

I have invited guest user, Guest user accepted invitation and he was able to see the applications on first time login. when user logout and tried to login again with gmail id ,it says that "You can't sign in here with a personal account. Use your work or school account instead." In this scenario when I gave my User principal name, it took me to password screen and when I enter password it says password is incorrect.

I'm very sure password is correct and I tried this couple of times with different email id, but issue persists for all guest users, Am I doing anything wrong.

Thanks,
Naveen

Microsoft Entra ID
Microsoft Entra ID
A Microsoft Entra identity service that provides identity management and access control capabilities. Replaces Azure Active Directory.
18,600 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Christian Strowitzki 6 Reputation points
    2021-06-15T09:30:12.99+00:00

    Hi,
    we see the same behaviour with the guest accounts we have created. I don't think it has something to do with the "supported account types" setting of the application itself. The problem is that https://myapplications.microsoft.com won't allow private Microsoft accounts to login. Using the link that ist mentioned in the invitation mail - https://account.activedirectory.windowsazure.com - works for us.
    From there, the guest user can login and is redirected to https://myapplications.microsoft.com. If this is expected behaviour, this is very irritating and badly communicated by Microsoft (i haven't found any official document on this behavior yet).

    Regards
    Christian

    1 person found this answer helpful.
    0 comments No comments

  2. James Hamil 20,491 Reputation points Microsoft Employee
    2021-05-12T20:18:11.687+00:00

    Hi @Naveen , from this thread, have you enabled personal Microsoft accounts in your settings?

    vRGcm.png

    Please check your authentication settings and wait a few minutes for it to permeate, and then see if it works. If not please let me know!

    If this answer helped you, please mark it as "Verified" so other users may reference it.

    Thank you,
    James

    0 comments No comments