Cannot publish azure synapse main branch - ranamed resource

Paul Hernandez 611 Reputation points Microsoft Employee
2021-05-12T15:41:30.99+00:00

Hi everyone,

We are currently working with synapse and git for the workspaces.

We have the following problem after this sequence:

  1. We have created a feature branch from main, let's call it ft_branch_01
  2. We implemented a pipeline
  3. We created a PR and then merged the feature branch with the main branch but we have not deleted the branch
  4. Other developers also created new branches from main after that.
  5. I applied some changes in the ft_branch_01 including renaming some datasets and data flows
  6. Created again a PR and merged the changes
  7. Tried to publish the main with the renamed objects and get the following error:

Error code: OK
Inner error code: DataFactoryResourceNotInRenamableState
Message: The Dataset DS__DWH in the workspace: {workspaceName} in subscription: {subscription ID} and resource group: {group name} cannot be renamed as new resource DS_DWH is not available or another operation is already in progress for this new resource. Current state: Succeeded

Nothing is currently running on the server and everyone stopped the debug sessions.

Any help will be appreciated.

BR. Paul

Azure Synapse Analytics
Azure Synapse Analytics
An Azure analytics service that brings together data integration, enterprise data warehousing, and big data analytics. Previously known as Azure SQL Data Warehouse.
4,103 questions
0 comments No comments
{count} votes

Accepted answer
  1. Samara Soucy - MSFT 5,046 Reputation points
    2021-05-13T03:05:43.447+00:00

    The most likely cause is a naming conflict, especially if it is only affecting that single dataset. There are a couple options for trying to clear the error. If you can't rename anything or these don't fix it, please do let me know so we can investigate further.

    First option- safest:

    1. Try renaming the dataset to something you are absolutely sure is unique, even if you end up changing it back later.
    2. If that clears the error and there is no other dataset with the same name you can try changing it back to 'DS__DWH'

    Second option

    1. Temporarily disconnect Git Integration. Since all related Pipelines and other resources are stored in Git, so it should be safe to disconnect.
    2. Delete all Pipelines in Live mode.
    3. Connect Git Integration again and avoid selecting “Import existing to Repo”.
    4. Check all resources and rename pipelines.
    5. Publish again after committing all to the master branch.
    2 people found this answer helpful.

1 additional answer

Sort by: Most helpful
  1. Samara Soucy - MSFT 5,046 Reputation points
    2021-05-18T23:51:51.44+00:00

    I'm so glad to hear it worked for you!

    I don't know how you are managing your code, so you may be doing these first two already.

    1. It looks like you may already be using a set naming scheme, but if it was an issue where you tried to rename the resource to something in use elsewhere then having a set scheme of making the names a bit longer so they are less likely to collide.
    2. Take a look at your branching strategy. I haven't tested it with Synapse, but in other scenarios I've had issues with things like continuing a feature branch after a merge when the merge type is squash-commit.
    3. It's possible there's something on our side causing either an error message that isn't reflecting the actual problem or metadata got into a bad state. If so, hopefully this will be a one-off issue and you won't see it again. If it repeats and you are sure it isn't a naming conflict on your repo, then please do reach out and we'll look into it further. You can open a new thread @ me or send an email to AzCommunity@microsoft.com. If you do decide to send and email, please send it to my attention and include a link to this thread so it gets routed to me.
    0 comments No comments