Xamarin Device Manager missing API Level 28

Jakob Aagesen 1 Reputation point
2021-05-13T12:55:49.747+00:00

hi
I am continuously running into emulator problems. My project is targeting Android 9.0 (API Level 28 - Pie).
So i want to make a new emulator that supports that version. I tried to make many different emulators with no luck getting it to run, but in this example i have made this emulator:
96366-device-settings.jpg

when i start it, it starts up with a black screen and then terminates again with no error message or anything.
This is the SDK and platform i have installed:
96307-platform.jpg

96348-sdk-tool.jpg

I am running Visual studio 2019 community edition on a windows 10 Home edition.
I am not trying to start the emulator via the debugger in Visual Studio. It is only the emulator i am starting directly from Xamaring Android Device Manager.
I cannot figure you why it stops. i have had an emulator running before, so it's not because my pc cant handle emulators. Can somebody help me out here?

Xamarin
Xamarin
A Microsoft open-source app platform for building Android and iOS apps with .NET and C#.
5,253 questions
0 comments No comments
{count} votes

2 answers

Sort by: Most helpful
  1. Leon Lu (Shanghai Wicresoft Co,.Ltd.) 63,921 Reputation points Microsoft Vendor
    2021-05-13T14:38:58.347+00:00

    Hello,​

    Welcome to our Microsoft Q&A platform!

    Based on your description, I think you do not enable the Hardware acceleration for emulator, you can refer to the following link to enable the Accelerating with Hyper-V or HAXM

    https://learn.microsoft.com/en-us/xamarin/android/get-started/installation/android-emulator/hardware-acceleration?pivots=windows

    Best Regards,

    Leon Lu


    If the response is helpful, please click "Accept Answer" and upvote it.

    Note: Please follow the steps in our documentation to enable e-mail notifications if you want to receive the related email notification for this thread.


  2. Jakob Aagesen 1 Reputation point
    2021-06-11T22:56:50.16+00:00

    hi again
    thank you, Appreciate your reply.
    I have now tried to install Android Studio and created an emulator from that. This gave same result as with Visual Studio. I am unable to create an emulator that will start up correctly.
    This is very weird, because i have run emulators on my pc with Visual studio and Xamarin Android device manager.
    Any suggestions, what the next step should be for me to solve my problem?

    0 comments No comments