After updating to .Net Core Runtime 2.1.28, Windows Update wants to install 2.1.25 security update but fails

Epp, Nathan 1 Reputation point
2021-05-13T22:17:12.017+00:00

I have several Windows Server 2016 and 2019 servers that applied the May update for .NET Core Runtime to 2.1.28. Subsequently, Windows update now things that these servers need the 2.1.25 .NET Core security update... but when you try to install it, Windows Update fails with 0x80070643 error.

I am also seeing this with .NET Core Runtime 3.1.15 and the 3.1.12 security update.

.NET Runtime
.NET Runtime
.NET: Microsoft Technologies based on the .NET software framework.Runtime: An environment required to run apps that aren't compiled to machine language.
1,100 questions
{count} votes