stop MS Edge scrolling

Bryan Kelly 286 Reputation points
2021-05-13T22:59:58.7+00:00

Windows 10, Edge 90.0.818.56

When a page is scrolled, Edge does not stop immediately, or even quickly. It keeps scrolling, slows down, and eventually stops. When there is a link to click, I must chase the link for a while before being able to click it. My hands have tremors and chasing the link to click it is frustrating.
How can it be configured to stop scrolling immediately?

Microsoft Edge
Microsoft Edge
A Microsoft cross-platform web browser that provides privacy, learning, and accessibility tools.
2,038 questions
{count} votes

2 answers

Sort by: Most helpful
  1. Bryan Kelly 286 Reputation points
    2021-05-15T01:34:17.477+00:00
    1. I have Chrome but dislike it popping up new tabs about a minute after it has started. It scrolls a bit after I stop, but not as much as edge.
    2. Yes, I use the scroll wheel on the mouse. Cursor keys don't do the job.

    but, I am trying some pages and it is not doing the same. Unfortunately I did not save the web sites and I cannot get the behavior now. I will try to watch for that and get back here later.

    Thank you for taking the time to post.

    16 May 2021, Edit
    I just followed a link to this site: https://www.sandiegouniontribune.com/opinion/letters-to-the-editor/story/2021-05-16/opinion-cryptocurrency-abuse-must-come-to-an-end

    When scrolling to find the comments the screen did the long slowing down scroll when using the mouse wheel. The images and text took, maybe 1/4 to 1/3 the screen to stop. Using the Page up/down buttons is better. I opened the page with Chrome and it was much better. But I really dislike that Chrome waits a minute or so after opening then opens more tabs and sometimes an email tab and puts me there mid keystroke.


  2. JoeZ 1 Reputation point
    2022-10-07T01:03:30.403+00:00

    I know this is an old post, but I was having the exact same issue, but for some reason after reading YuZhou-MSFT's first reply it dawned on me that the problem might be with my mouse settings.

    So I checked my Logitech settings, turned off smooth scrolling there, and now my scrolling doesn't have that annoying slow-down anymore!
    Just a crisp, clean stop!

    0 comments No comments